Closed Bug 1401972 Opened 2 years ago Closed 2 years ago

Devtools Reps: update bundle to v0.14.0

Categories

(DevTools :: Shared Components, defect)

defect
Not set

Tracking

(firefox57 verified, firefox58 verified)

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Attachment #8911060 - Flags: review?(bgrinstead)
Comment on attachment 8911060 [details]
Bug 1401972 - Release: Update reps bundle to 0.14.0; .

https://reviewboard.mozilla.org/r/182278/#review187856
Attachment #8911060 - Flags: review+
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af867bbd41ee
Release: Update reps bundle to 0.14.0; r=nchevobbe.
https://hg.mozilla.org/mozilla-central/rev/af867bbd41ee
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8911060 [details]
Bug 1401972 - Release: Update reps bundle to 0.14.0; .

This is an update to the Reps bundle, the underlying sets of components the devtools use to display variables. The bundle is used in the console, the debugger, the dom panel, the json viewer and the inspector.
This patches fixes an important perf regression as well as an issue that prevented to expand some object in the console and the debugger

[Feature/Bug causing the regression]:
https://bugzilla.mozilla.org/show_bug.cgi?id=1399460

[User impact if declined]:
Serious slow-downs when using the console with a lot of logged object. Impossibility to expand some objects in the console.

[Is this code covered by automated tests?]:
Yes

[Has the fix been verified in Nightly?]:
Yes

[Needs manual test from QE? If yes, steps to reproduce]: 
Yes,
STR: 
1. Open the console
2. Evaluate
```
var map1 = new Map([]); 
map1.set(map1, 1); map1;
```
3. Expand the object, then the `<entries>` node, then the <key> one

Expected results:
It shows child nodes of the key node (which should be `Map → 1`)

[List of other uplifts needed for the feature/fix]:

[Is the change risky?]: No
[Why is the change risky/not risky?]: Because we added some guards to not fail when expanding objects (and added tests to make sure everything is fine), and remove unecessary event listeners that we didn't used at all and were causing the performance issue.

[String changes made/needed]:
Attachment #8911060 - Flags: approval-mozilla-beta?
Comment on attachment 8911060 [details]
Bug 1401972 - Release: Update reps bundle to 0.14.0; .

Improve performance. We usually don't like to take this kind of patches in beta because we know that performance improvements are usually causing regressions.
However, it is early in the beta cycle, so, taking it.
Should be in 57b4 (gtb tomorrow Thursday)
Attachment #8911060 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [good first verify]
Flags: qe-verify+
Verified fixed using the latest Nightly 58.0a1 (2017-11-06)and FF Beta 57.0b14 on Windows 10 x64, Ubuntu 16.04 x64 and Mac OS X 10.12.
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.