Closed Bug 1401977 Opened 4 years ago Closed 4 years ago

Dragging images out of browser to desktop should keep the file's extension

Categories

(Core :: DOM: Copy & Paste and Drag & Drop, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1389836
Tracking Status
firefox57 --- affected

People

(Reporter: sevaan, Unassigned)

Details

I feel like this may be a regression.

STR:

1. Go to a webpage with an image
2. Drag the image from the page onto your desktop

The file does not have a file extension (on Mac).

What should happen is that if I drag a jpg out of a page onto my computer, it should be a .jpg file that appears on my desktop.
Component: General → Drag and Drop
Product: Firefox → Core
Can confirm this bug. Looks like it appeared with Firefox 57, don't think it was there before. Hope it will be fixed soon actually.
I've noticed this as well. As of v57, Firefox seems to no longer see file extensions when dragging images from sites onto the desktop in Windows 10.

STR:

1. visit, say, https://imgur.com/a/0k1Lj,
2. drag-and-drop the first image from the browser to the desktop,
3. note the resulting filename.

in Firefox 56, this gives the file "QCp9y7n.jpg", but 57 and 58 use a filename "QCp9y7n" without any extension, which becomes rather cumbersome if you have to work with portfolio selection, image curation, or even just browsing https://www.reddit.com/r/redpandas and saving the cute ones to a folder by dragging them over =)
it's a common practice to drag images to desktop, so this regression (i confirm in macOS 57beta and current nightly) is quite important for v57 final
Seems like a duplicate of 1389836.
Believed to be a duplicate of bug 1389836. If this isn't related to handlers.json, please reopen.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389836
You need to log in before you can comment on or make changes to this bug.