Closed Bug 1402079 Opened 4 years ago Closed 4 years ago

browser/base/content/test/performance/browser_windowopen_reflows.js fails on windows 10 VM (not hardware)

Categories

(Firefox :: General, defect)

53 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

Attachments

(1 file)

we are working to run our windows 10 browser-chrome tests on a virtual machine instead of hardware- we find that browser/base/content/test/performance/browser_windowopen_reflows.js is perma-failing:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9bd0a7962475ed9b61b5581ba8923013a434f128&selectedJob=132496318

with this in the log file:
15:22:29    ERROR -  761 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_windowopen_reflows.js | unexpected uninterruptible reflow
15:22:29     INFO -  [
15:22:29     INFO -  	"handleEvent@chrome://browser/content/tabbrowser.xml:6864:19",
15:22:29     INFO -  	"EventListener.handleEvent*tabbrowser-tabs_XBL_Constructor@chrome://browser/content/tabbrowser.xml:6282:11",
15:22:29     INFO -  	""
15:22:29     INFO -  ]
15:22:29     INFO -   - false == true - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/performance/head.js :: reflow :: line 122
15:22:29     INFO -  Stack trace:
15:22:29     INFO -  chrome://mochitests/content/browser/browser/base/content/test/performance/head.js:reflow:122
15:22:29     INFO -  chrome://browser/content/tabbrowser.xml:handleEvent:6864
15:22:29     INFO -  762 INFO TEST-PASS | browser/base/content/test/performance/browser_windowopen_reflows.js | expected uninterruptible reflow: '[
15:22:29     INFO -  	"select@chrome://global/content/bindings/textbox.xml:115:11",
15:22:29     INFO -  	"focusAndSelectUrlBar@chrome://browser/content/browser.js:2283:5",
15:22:29     INFO -  	"_handleURIToLoad/<@chrome://browser/content/browser.js:1686:11",
15:22:29     INFO -  	"promise callback*_handleURIToLoad@chrome://browser/content/browser.js:1684:5",
15:22:29     INFO -  	"_delayedStartup@chrome://browser/content/browser.js:1456:5",
15:22:29     INFO -  	"EventListener.handleEvent*onLoad@chrome://browser/content/browser.js:1401:5",
15:22:29     INFO -  	"onload@chrome://browser/content/browser.xul:1:1",
15:22:29     INFO -  	""
15:22:29     INFO -  ]' - true == true -
15:22:29     INFO -  763 INFO Leaving test bound

I know we removed a reflow to get this working on windows10 hardware (bug 1397229):
https://reviewboard.mozilla.org/r/178464/diff/3#index_header

possibly we need to add that back.
:mconley- I see you helped out in bug 1397229- do you know a bit more about this test and how we could make it better?
Flags: needinfo?(mconley)
Joel, the screen resolution is still 1280x1024 and not 1600x1200 as on the hardware machines:

https://treeherder.mozilla.org/logviewer.html#?job_id=132496318&repo=try&lineNumber=1588

So this might be related to this.
I am not able to set it at 1600x1200, the windows7 vm is at 1280x1024- I assume the graphics adapter we have for windows10-VM does not have a 1600x1200 option.
It might be sufficient (if somewhat hacky) to, at runtime, detect the screen dimensions when deciding which reflows we'll accept.

I'm not sure what that threshold should be - might need a little tuning.

Is that enough information?
Flags: needinfo?(mconley) → needinfo?(jmaher)
this is looking good on try, both for hardware and vm:
https://treeherder.mozilla.org/#/jobs?repo=try&author=jmaher@mozilla.com&fromchange=70cb11b61339cdee552534d120d1b71fe6306cfe
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Flags: needinfo?(jmaher)
Attachment #8911552 - Flags: review?(mconley)
Comment on attachment 8911552 [details] [diff] [review]
support different resolutions for reflows

Review of attachment 8911552 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8911552 - Flags: review?(mconley) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/94c3cdebb0b0
browser/base/content/test/performance/browser_windowopen_reflows.js fails on different screen resolutions. r=mconley
Duplicate of this bug: 1402610
Whiteboard: [checkin-needed-beta]
https://hg.mozilla.org/mozilla-central/rev/94c3cdebb0b0
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
You need to log in before you can comment on or make changes to this bug.