Closed Bug 1402103 Opened 3 years ago Closed 3 years ago

Crash in AsyncShutdownTimeout | Places Connection shutdown | PlacesUtils read-only connection closing as part of Places shutdown

Categories

(Toolkit :: Places, defect)

56 Branch
Unspecified
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1326309
Tracking Status
firefox55 --- unaffected
firefox56 --- affected
firefox57 --- affected

People

(Reporter: skywalker333, Unassigned)

Details

(Keywords: crash, topcrash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-3ebf9209-43a6-4ef2-a331-421a10170921.
=============================================================

Firefox 57.0a1 Crash Report [@ AsyncShutdownTimeout | Places Connection shutdown | PlacesUtils read-only connection closing as part of Places shutdown ]

Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	mozglue.dll 	mozalloc_abort(char const* const) 	memory/mozalloc/mozalloc_abort.cpp:33
1 	xul.dll 	NS_DebugBreak 	xpcom/base/nsDebugImpl.cpp:417
2 	xul.dll 	nsDebugImpl::Abort(char const*, int) 	xpcom/base/nsDebugImpl.cpp:148
3 	xul.dll 	XPTC__InvokebyIndex 	xpcom/reflect/xptcall/md/win32/xptcinvoke_asm_x86_64.asm:97
4 		@0x5ac2ba184f 	
5 	xul.dll 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp:1282
6 	xul.dll 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:929
7 	xul.dll 	js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp:495
8 	xul.dll 	Interpret 	js/src/vm/Interpreter.cpp:3084
9 	xul.dll 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp:435
10 	xul.dll 	js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp:513
11 	xul.dll 	PromiseReactionJob 	js/src/builtin/Promise.cpp:1199
12 	xul.dll 	js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp:495
13 	xul.dll 	JS::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JS::HandleValueArray const&, JS::MutableHandle<JS::Value>) 	js/src/jsapi.cpp:2965
14 	xul.dll 	mozilla::dom::PromiseJobCallback::Call(JSContext*, JS::Handle<JS::Value>, mozilla::ErrorResult&) 	dom/bindings/PromiseBinding.cpp:21
15 	xul.dll 	mozilla::dom::PromiseJobCallback::Call(char const*) 	dist/include/mozilla/dom/PromiseBinding.h:104
16 	xul.dll 	mozilla::PromiseJobRunnable::Run() 	xpcom/base/CycleCollectedJSContext.cpp:209
17 	xul.dll 	XPCJSContext::AfterProcessTask(unsigned int) 	js/xpconnect/src/XPCJSContext.cpp:1190
18 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:1055
19 	xul.dll 	XPTC__InvokebyIndex 	xpcom/reflect/xptcall/md/win32/xptcinvoke_asm_x86_64.asm:97
20 		@0xfffe005acf1f3500 	
21 	xul.dll 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp:1282
22 	xul.dll 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:929
23 		@0x105a07a4634
Top Crasher #25.

Top Crashers for Firefox 57.0a1
Top 50 Crashing Signatures. 7 days ago through 8 minutes ago. 

First Appearance 2017-08-06.
Component: Untriaged → Places
Product: Core → Toolkit
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1326309
You need to log in before you can comment on or make changes to this bug.