Downloads subview in Library has icons that are too small

VERIFIED FIXED in Firefox 57

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Dolske, Assigned: mikedeboer)

Tracking

Trunk
Firefox 58
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox57+ verified, firefox58 verified)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Posted image Screenshot
The icons in the Downloads subview are too small. Looks like something isn't applying the display scaling? (Current Nightly, Retina display, OSX)
(Reporter)

Comment 1

2 years ago
Notice that the icons are the expected size in the downloads button panel (non-Library view).
(Assignee)

Comment 2

2 years ago
This is in fact the intended size/ design, but we may revisit this since Aaron mentioned making these icons larger as well.

Updated

2 years ago
Flags: needinfo?(abenson)
Flags: qe-verify+
Priority: -- → P3
QA Contact: gwimberly
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]

Comment 3

2 years ago
Behold, the embiggened icons: https://mozilla.invisionapp.com/share/A2DOBNQJE#/255377231_Menus_Downloads_Bigger_Icons
Flags: needinfo?(abenson)
(Assignee)

Updated

2 years ago
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Priority: P3 → P1

Comment 5

2 years ago
mozreview-review
Comment on attachment 8915634 [details]
Bug 1402126 - Change the icon size of Download items in the Library's Downloads panel view to 32px.

https://reviewboard.mozilla.org/r/186824/#review192686

Can't see the spec, but this looks reasonable enough to me.
Attachment #8915634 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 6

2 years ago
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a1188a2bf9ee
Change the icon size of Download items in the Library's Downloads panel view to 32px. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/a1188a2bf9ee
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
(Assignee)

Comment 8

2 years ago
Since this is a quite simple CSS change, do we want to uplift this to 57?
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Updated

2 years ago
Flags: needinfo?(abenson)

Comment 9

2 years ago
(In reply to Mike de Boer [:mikedeboer] from comment #8)
> Since this is a quite simple CSS change, do we want to uplift this to 57?

Probably, yeah.
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Comment 10

2 years ago
[Tracking Requested - why for this release]: This panel will be introduced in Fx 57 and this update to larger icons will ship in 58 for sure. It'd be nice to ship a consistent panel view _starting_ with 57 and not introduce a visual change like this one version later.

Comment 11

2 years ago
(In reply to Mike de Boer [:mikedeboer] from comment #8)
> Since this is a quite simple CSS change, do we want to uplift this to 57?

Yes, that would be ideal.
Flags: needinfo?(abenson)
(Assignee)

Comment 12

2 years ago
Comment on attachment 8915634 [details]
Bug 1402126 - Change the icon size of Download items in the Library's Downloads panel view to 32px.

Approval Request Comment
[Feature/Bug causing the regression]: This panel will be introduced in Fx 57 and this update to larger icons will ship in 58 for sure. It'd be nice to ship a consistent panel view _starting_ with 57 and not introduce a visual change like this one version later.
[User impact if declined]: Icons are too small in the Downloads subview.
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: No.
[Needs manual test from QE? If yes, steps to reproduce]: Yes, the icons in the Downloads subview inside the Library should appear double the current size, compared to 57.
[List of other uplifts needed for the feature/fix]: n/a.
[Is the change risky?]: Minor risk.
[Why is the change risky/not risky?]: This is a graphical CSS-only change that is contained to this view.
[String changes made/needed]: n/a.
Attachment #8915634 - Flags: approval-mozilla-beta?
Comment on attachment 8915634 [details]
Bug 1402126 - Change the icon size of Download items in the Library's Downloads panel view to 32px.

Photon polish, beta57+
Attachment #8915634 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Reproduced this issue on affected Nightly build 57.0a1 (2017-09-22).

Verified fixed on latest Nightly 58.0a1 (2017-10-13) and Beta 57.0b8 (20171013042429) across platforms: Windows 10 x64, Mac OS X 10.13 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.