Closed Bug 1402315 Opened 2 years ago Closed 8 months ago

Implement the new photon style for the search/filter input

Categories

(DevTools :: Inspector, enhancement, P2)

enhancement

Tracking

(firefox57 fix-optional)

RESOLVED DUPLICATE of bug 1508219
Tracking Status
firefox57 --- fix-optional

People

(Reporter: gl, Assigned: rajdeep.nanua)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → rajdeep.nanua
Status: NEW → ASSIGNED
Depends on: devtools-visual
Summary: Remove the toolbar in the inspector → Implement the new photon style for the search/filter input
Priority: -- → P2
Comment on attachment 8911289 [details]
Bug 1402315 - Part 1: Implement the new photon style for the search/filter input.

https://reviewboard.mozilla.org/r/182786/#review203968

::: devtools/client/themes/common.css:392
(Diff revision 1)
>  
>  /* Text input */
>  
>  .devtools-textinput,
>  .devtools-searchinput,
>  .devtools-filterinput {

Add background-color: transparent

::: devtools/client/themes/common.css
(Diff revision 1)
>  .devtools-searchbox {
>    display: inline-flex;
>    flex: 1;
>    height: 23px;
>    position: relative;
> -  padding: 0 3px;

Don't remove this padding.

::: devtools/client/themes/rules.css
(Diff revision 1)
>  
>  #ruleview-toolbar {
>    display: flex;
>  }
>  
> -#ruleview-toolbar > .devtools-searchbox:first-child {

Don't remove this.
Attachment #8911289 - Flags: review?(gl)
No longer depends on: devtools-visual
Product: Firefox → DevTools
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1508219
You need to log in before you can comment on or make changes to this bug.