Pressing "back" causes textarea contents to be reset.

RESOLVED DUPLICATE of bug 138892

Status

()

Core
Document Navigation
RESOLVED DUPLICATE of bug 138892
16 years ago
9 years ago

People

(Reporter: Janne Jalkanen, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Steps to replicate: Go to "http://www.ecyrd.com/JSPWiki/Wiki.jsp?page=SandBox".
 Press "Edit this page".  Enter some data.  Press "Preview".  Note that
modifications are visible.  Press "Back".  Note that modifications have
disappeared from the textarea component.

This occurs both with mozilla-1.0rc1 and the 2002042121 build, but did not occur
with 0.9.9 or earlier.  Cache settings in rc1 have seemingly no effect to this
phenomenon.

My suspicion is that this has something to do with cache expiry control, but
setting explicit "Last-Modified", "Expires", and/or "Cache-Control" -headers
does not seem to affect the result.

Comment 1

16 years ago
I don't understand where the "Back" button comes from, one moment you're
describing what to do in Composer, the next you're describing a Navigator
button; and I don't understand what you mean by "the textarea component"

reporter, could you please post a more descriptive account of how to reproduce
this bug so as to help us test it

thanks :)
(Reporter)

Comment 2

16 years ago
There is an "Edit this page" button on the bottom of the screen (or on the left 
side menu) of the JSPWiki site.

The back button refers to the browser's back button.

Sorry for the confusion, here is a better attempt at explaining:

1. Go to http://www.ecyrd.com/JSPWiki/Wiki.jsp?page=SandBox

2. On this page, press "Edit this page" -link, available on the left hand menu, 
or at the bottom of the page.  You will receive a beautifully colored page, 
with a single textarea element that allows you to modify the text of the page.

3. Type in "qwertyiop" or something else at any point of the text box.  I 
recommend the first line.

4. Press "Preview" -button, located just below the textarea component.

5. Inspect the new page.  It should have your modification visible 
(text "qwertyiop" on the first line).

6. Press the browser's back button.  You are returned to the beautifully-
colored page.

7. The textarea component does no longer contain the modifications you made, 
but the original text of the page.  The contents have been reset to their 
previous value, and your modifications have been forgotten.  This I feel to be 
a problem.

Does this help?
To session history.  Confirmed that this is a problem, linux trunk build
2002-04-25-07.  The page _is_ cached, so it's not that we're not reading it from
cache...

Janne, thanks for the excellent instructions!
Assignee: gordon → radha
Status: UNCONFIRMED → NEW
Component: Networking: Cache → History: Session
Ever confirmed: true
QA Contact: tever → claudius

Comment 4

16 years ago
thanks Janne for being so clear. I'd thought you meant 'Edit Page' on the
browser's menu which leads you to Composer which has a 'Preview', as  because I
wasn't paying as much attention as I could have

I see this bug with Mozilla 2002042510, Windows 2000

OS should be changed to 'All'

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 138892 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.