Duplicate Tabs Closer doesn't work on Fennec

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: pwd.mozilla, Unassigned)

Tracking

57 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170920135429

Steps to reproduce:

It works perfectly on desktop and makes all of the proper API calls but for some reason it doesn't display duplicate tabs or have the ability to close them.
tracking-fennec: --- → ?
OS: Unspecified → Android
Hardware: Unspecified → ARM
Thanks for filing this!
Do you have STR for this?
Also the app version and links you were using?
Flags: needinfo?(pwd.mozilla)
(Reporter)

Comment 2

2 years ago
STR

1. Open Fennec
2. Open a new tab
3. Open https://addons.mozilla.org/en-US/firefox/addon/duplicate-tabs-closer/ in that tab
4. Open another new tab
5. Open https://addons.mozilla.org/en-US/firefox/addon/duplicate-tabs-closer/ in that tab
6. Hope that bug 1401566 isn't preventing you from accessing your add-on actions
7. Tap Duplicate Tabs Closer
Flags: needinfo?(pwd.mozilla)
Hi Wesly
Please help prioritize for investigation.
Flags: needinfo?(wehuang)

Comment 4

2 years ago
Hi Andy, is this something your team is able to look into? Thanks.
Flags: needinfo?(wehuang) → needinfo?(amckay)
Confirmed using STR in Comment 2.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

2 years ago
According to AMO, that extension is not listed as compatible with Android.

Running the add-on, I get the following error:

TypeError: chrome.windows is undefined popup.js:188:3

The add-on uses the windows API, which as documented is not supported on Android:

https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/windows

There is a suggestion in bug 1404014 that we implement a light browser.windows API, that might be able to work for this add-on. Or it could detect the presence (or lack there of) of the API and work around that. 

For these reasons I'm going to close as invalid, but duping over to bug 1404014 might be appropriate too.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(amckay)
Resolution: --- → INVALID
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.