Closed Bug 1402730 Opened 2 years ago Closed 2 years ago

Crash in nexttowardf

Categories

(Firefox for Android :: Toolbar, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1395138
Tracking Status
firefox58 --- affected

People

(Reporter: njn, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-069f103c-9701-42bb-8cfe-8fbd30170923.
=============================================================

This is the #4 topcrash in Nightly 20170923100046. It has occurred 50 times in the past 7 days, across 39 installations, in both 57 and 58.

Stack traces involve ContainerRender<ContainerLayerComposite> and libGLES_mali.so.

Miko, any ideas?
Flags: needinfo?(mikokm)
I think this is a dupe of bug 1395138 with different inlining.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1395138
Flags: needinfo?(mikokm)
Crash Signature: [@ nexttowardf] → [@ nexttowardf] [@ @0x0 | nexttowardf]
crashes with this signature are still happening on 57.0b9 - is this really a dupe?
Flags: needinfo?(continuation)
(In reply to [:philipp] from comment #2)
> crashes with this signature are still happening on 57.0b9 - is this really a
> dupe?

The crash in comment 0 is a dupe. The remaining signatures seem to be a bunch of different things. nexttowardf should probably be added to the skip list or something. I don't actually see any references to it in the code base, and it seems like some kind of library function.
Flags: needinfo?(continuation)
I wonder if the nexttowardf is some odd artifact of symbolification on Android. Some of the crashes have the JIT calling right into it, which doesn't make much sense to me.
You need to log in before you can comment on or make changes to this bug.