audi.de - Javascript menus don't work - LAYERS

VERIFIED DUPLICATE of bug 82931

Status

--
critical
VERIFIED DUPLICATE of bug 82931
17 years ago
4 years ago

People

(Reporter: sven.papperitz, Assigned: tristan)

Tracking

Details

(Whiteboard: [SYNTAX-HTML][LAYERS], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

The JAVAscriptmenues for the URL's www.audi.de and www.ferrari-deutschland.de
doesn't work. You have to compare it with IP or Opera to see what I mean

Reproducible: Always
Steps to Reproduce:
1.PLease read the describtion
2.
3.

Actual Results:  Navigation on these sites is no possible

Expected Results:  Menues should be displayed, but nothing will be displayed.

Comment 1

17 years ago
This is the browser sniffing used by the site in global.js:

function checkBrowser(){
	this.ver = navigator.appVersion;
	this.dom = document.getElementById?1:0;
	this.ie6 = (this.ver.indexOf("MSIE 6")>-1 && this.dom)?1:0;
	this.ie55 = (this.ver.indexOf("MSIE 5.5")>-1 && this.dom)?1:0;
	this.ie5 = (this.ver.indexOf("MSIE 5")>-1 && this.dom)?1:0;
	this.ie4 = (document.all && !this.dom) ? 1:0;
	this.ns5 = (this.dom && parseInt(this.ver) >= 5) ? 1:0;
	this.ns4 = (document.layers) ? 1:0;
	this.bw  = (this.ie5 || this.ie4 || this.ns4 || this.ns5 || this.ie55 || this.ie6);
	this.os  = (this.ver.indexOf("Macintosh")>-1)? "mac":"pc";
	this.ie  = (this.ie5 || this.ie4 || this.ie55 || this.ie6);
	this.ns  = (this.ns4 || this.ns5);
	this.client = (this.ie) ? "ie" : "ns";
	return this;
}

It's clear that Mozilla and Netscape6 will be classified as ns5 (which is
correct) _and therefore_ into ns (which is dangerous as Netscape4 uses
document.layers)

And it really serves us document.layers. In init.js we have:

	if(is.ns){										// NS:
		origWidth = innerWidth;
		origHeight = innerHeight;
		window.onresize = redoNS;					// map onresize to redoNS (which is a document.reload) 

		document.layers["menuNs"].visibility = "show"; // Fix bug where menu was showed
while page was loading. Jose
		document.layers["bCumb"].visibility = "show";  // Fix bug where the rollover did
not work. Jose

Mozilla has also problem with the following in crosssfeature.js (there is a
JavaScript warning):

else if (is.ns)				// for netscape:
  {	
    this.tabs[i].left = offset.x - 1;	// set the position or the layers to 
    this.tabs[i].top  = (i==3)? 
    offset.y:offset.y + 29;			// the position of the anchor
  }


To wrap it up: its is a LAYERS problem.

-> Europe: West (where German ech Evangelism belongs)
Assignee: piskozub → nitot
Component: Europe: Central → Europe: West
QA Contact: pali → caillon
Summary: Javascriptmenues doesn't work → [www.audi.de] Javascriptmenues doesn't work - LAYERS

Comment 2

17 years ago
Confirming the bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
The QA Contact for Europe: West has changed to
brantgurganus2001@cherokeescouting.org.  If there is a reason for you to stay as
the QA Contact, feel free to change back.
QA Contact: caillon → brantgurganus2001

Updated

17 years ago
Severity: major → critical
Priority: -- → P2

Comment 4

17 years ago
bugzillamat: Please do not change Priority if you are not the owner of the bug
(the person assigned to it). 

As concerns Severity, what do you understand by Critical in the case of an
evangelism bug? 
Priority: P2 → --

Comment 5

17 years ago
I get the following error:

Error: this.tabs[0] has no properties
Source File: http://www.audi.com/include/js/crossfeature.js
Line: 81

Error: cf has no properties
Summary: [www.audi.de] Javascriptmenues doesn't work - LAYERS → audi.de - Javascript menus don't work - LAYERS
Whiteboard: [SYNTAX-HTML][LAYERS]

Comment 6

17 years ago
I think that this is also a problem with http://www.victoriassecret.com/.  It
runs a little javascript to determine browser capabilities and also appears to
reach the conclusion that Mozilla 202062304 needs to be given layers.  

I've not actually traced the code.  I've just confirmed that the menus do not
operate properly.  The second level menus fail to pop up.  The first level
highlighting as the mouse moves is incorrect.

*** This bug has been marked as a duplicate of 82931 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
Verifying.
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → German
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.