nytw.org - Some (but not all) asp files seem to be cause Mozilla to download them and save as files

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Stephan Golux, Unassigned)

Tracking

Details

(Whiteboard: [mime type], URL)

(Reporter)

Description

16 years ago
Go to the URL:

    http://nytw.org/flash/information.asp

On my Mozilla (1.0 RC1) it will not display this page.  Instead, it will bring
up a "Download File" dialog to save the file "information.asp" on my hard drive.

This is confusing because other asp pages seem to work fine.

NB - all working asp pages I have been able to confirm are over SSL.  I don't
know if this is relevant.

Page displays as expected in IE 5, Netscape 4.7, and Opera 3.21 and 5.01.
To evangelism.  The site just sends the wrong MIME type
(application/octet-stream instead of text/html).  Oh, and this page does not
work for me in NS4.7 either -- I get the save as dialog.
Assignee: law → doron
Status: UNCONFIRMED → NEW
Component: File Handling → US General
Ever confirmed: true
OS: Windows 98 → All
Product: Browser → Tech Evangelism
QA Contact: sairuh → zach
Hardware: PC → All
Version: other → unspecified

Comment 2

16 years ago
I think this bug should be solved. MS IIS defaults to the MIME type of
application/octet-stream for ASP files. A lot of administrators don't know
anything about MIME types and refuse to change their MIME type for ASP files.
Since the Helper Application settings of Mozilla does not allow users to edit
file extensions of the text/html MIME type th pages cannot be viewed within Mozilla.
Isn't is possible to add an user-interface where an user can add/remove file
extensions to/from the text/html MIME type in the Helper Applications settings
in order to get those ASP's displayed.
Here's another url that doesn't open within Mozilla. Mozilla instead asks to
open/ save the ASP-file. Look at http://www.exact.nl

Updated

15 years ago
Summary: Some (but not all) asp files seem to be cause Mozilla to download them and save as files → nytw.org - Some (but not all) asp files seem to be cause Mozilla to download them and save as files
Whiteboard: [mime type]

Comment 3

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 4

14 years ago
site has been redesigned, and now sends ASP as text/html
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.