Closed Bug 1403037 Opened 2 years ago Closed 2 years ago

TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js "undefined" == "google.com"

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 58.0

People

(Reporter: jorgk, Assigned: mhowell)

References

Details

(Keywords: intermittent-failure, Whiteboard: [Thunderbird-testfailure: X Windows])

Attachments

(1 file)

TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js | test_checkEnvironment - [test_checkEnvironment : 455] "undefined" == "google.com"

This comes from
https://dxr.mozilla.org/mozilla-central/rev/7e962631ba4298bcefa571008661983d77c3e652/toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js#455

which was added about one year ago:
https://hg.mozilla.org/mozilla-central/rev/0bf376ad9b85#l3.91

It only fails on Windows, not on Linux. Sorry, Mac currently broken, so I can't tell.

I've first seen it on Fri Sep 22, 2017, 1:36:07 here:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=e08911b56e26b2d7dbfd4d0cd4b1380555e70625&selectedJob=132611823

Georg (doesn't take NI) and Matt, can you shed some light onto this please.
Flags: needinfo?(mhowell)
Looks like it's bug 1400870 that broke this, but only by exposing an existing problem, not by doing anything wrong.

The reason it's failing now is this line:

https://hg.mozilla.org/releases/mozilla-beta/file/7e35ed4a8c47/toolkit/components/telemetry/tests/unit/test_TelemetryEnvironment.js#l894

which means that the data being looked for in the failing step isn't generated for Thunderbird (ironically enough as I recall that line was added to fix a different TB test failure). Prior to bug 1400870 this would have been silently ignored; now it generates a failure instead, probably correctly. To fix this we should skip running the steps that are failing if we did not run spoofAttributionData().
Flags: needinfo?(mhowell)
Thanks a lot for the quick attention!
(In reply to Matt Howell [:mhowell] from comment #1)
> Looks like it's bug 1400870 that broke this, but only by exposing an
> existing problem, not by doing anything wrong.

Thanks for fixing this Matt!
Assignee: nobody → mhowell
Comment on attachment 8912081 [details]
Bug 1403037 - Don't test attribution data in applications that don't use it.

https://reviewboard.mozilla.org/r/183462/#review188632
Attachment #8912081 - Flags: review?(alessio.placitelli) → review+
Duplicate of this bug: 1403036
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6f54019717c1
Don't test attribution data in applications that don't use it. r=Dexter
https://hg.mozilla.org/mozilla-central/rev/6f54019717c1
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 58.0
Comment on attachment 8912081 [details]
Bug 1403037 - Don't test attribution data in applications that don't use it.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1400870.
[User impact if declined]: None, but test failures on comm-beta
[Is this code covered by automated tests?]: Yes.
[Has the fix been verified in Nightly?]: Test only.
[Is the change risky?]: No, just added a test for "browser".
[Why is the change risky/not risky?]: See above.
[String changes made/needed]: None.
Attachment #8912081 - Flags: approval-mozilla-beta?
Comment on attachment 8912081 [details]
Bug 1403037 - Don't test attribution data in applications that don't use it.

Test only change do not require relman approval.
Attachment #8912081 - Flags: approval-mozilla-beta?
Ryan, do you know the way forward here? How does it get uplifted? I push it myself?
Flags: needinfo?(ryanvm)
Normally you'd just add [checkin-needed-beta] to the whiteboard, but no need to this time with the NI.
Flags: needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.