PAC: myIpAddress() returns IPv6 address

RESOLVED FIXED in mozilla1.4beta

Status

()

P2
major
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: ngoldber, Assigned: darin.moz)

Tracking

({helpwanted, platform-parity})

Trunk
mozilla1.4beta
helpwanted, platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
My proxy.pac stopped working in the 2002031312 build. Apparently this is due to
myIpAddress() having gone haywire. It used to return my IP address. Now it
returns "::ffff:xxx.xxx.xxx.xxx" where the xxx's represent my address. The
colons and 'ffff' are something I've never seen before (and they aren't there in
the Windows version of the same build). This caused my proxy logic to break
since my IP address was malformed. 
A rewrite of the script to discard leading garbage helps, but I have no idea
what's going on.
Neil, 0.9.9 isn't really the newest version, cound you try 1.0RC1 or maybe a
recent nightly?

Comment 2

17 years ago
+ regression, 4xp, mozilla1.0
cc: morse
(wonders if this is an IPv6 address format?)

please post a small PAC file that shows this problem as an attachment.
Keywords: 4xp, mozilla1.0, regression
QA Contact: benc → pacqa
Summary: myIpAddress() is broken in 0.9.9 on Linux → PAC: myIpAddress() is broken in 0.9.9 on Linux
Whiteboard: checkmac, checkwin
no answer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
linux-only (so far) -> pp, helpwanted to get attention.
that looks like IPv6 to me...
Status: RESOLVED → UNCONFIRMED
Keywords: mozilla1.0, regression → helpwanted, pp
Resolution: WORKSFORME → ---
Summary: PAC: myIpAddress() is broken in 0.9.9 on Linux → PAC: myIpAddress() is returns IPv6 addresss in Linux?
(Assignee)

Comment 5

16 years ago
hmm.. yeah, it probably makes sense to return the address as an IPv4 address
literal if the address is merely an IPv4-mapped-IPv6 address.  i wonder what the
standard for PAC says.
Assignee: new-network-bugs → darin
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → Future
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Summary: PAC: myIpAddress() is returns IPv6 addresss in Linux? → PAC: myIpAddress() returns IPv6 address under Linux (and other platforms that have IPv6 support)

Comment 6

16 years ago
PAC never envisioned support for IPv6. It is like most network address layer
protocols, it needs to be extended (and possibly re-purposed) for the new new
networking world.
(Assignee)

Updated

16 years ago
Target Milestone: Future → mozilla1.4alpha
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.4alpha → mozilla1.4beta
(Assignee)

Comment 7

16 years ago
since myIPAddress calls Resolve, this is a duplicate of bug 191715.

*** This bug has been marked as a duplicate of 191715 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 8

15 years ago
REOPEN: as depends.

Status: RESOLVED → REOPENED
Depends on: 191715
Resolution: DUPLICATE → ---

Comment 9

15 years ago
RESOLVED/FIXED (per Darin).

However, on my Mac, I seem to only get back 127.0.0.1 even though my mac has
IPv4 and IPv6 addresses on the ethernet interface.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
QA Contact: pacqa → benc
Resolution: --- → FIXED
Whiteboard: checkmac, checkwin

Updated

15 years ago
Summary: PAC: myIpAddress() returns IPv6 address under Linux (and other platforms that have IPv6 support) → PAC: myIpAddress() returns IPv6 address

Comment 10

15 years ago
*** Bug 238341 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
Darin:

in bug 191715, are you converting only IPv6 addresses to IPv4 that can be
mapped? What happens to IPv6 addresses that are untranslatable? Do you return
the IPv6 values?
You need to log in before you can comment on or make changes to this bug.