Closed Bug 1403118 Opened 3 years ago Closed 3 years ago

The lowest pixel of certain characters is cut off on Outlook Tasks

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
Tracking Status
firefox55 --- wontfix
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- verified
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected

People

(Reporter: JuliaC, Unassigned)

References

Details

[Affected versions]:
- 58.0a1 (2017-09-25)
- 57.0b3 build 1 (20170925150345)
- 56.0 build 5 (20170925181605)
- 55.0.3 build 2 (20170824053622)

[Affected platforms]:
- Windows 7 x64
- macOS 10.12	
- Ubuntu 16.04 x64

[Steps to reproduce]:
1. Launch Firefox 
2. Go to https://outlook.live.com/ and sign in using valid Outlook credentials
3. Navigate to Outlook Tasks from the left corner Outlook app menu button
4. Click the New button in order to create a new task 
5. Go to the subject section and give a task name 
- type some random characters and inspect them
6. Save the task and inspect the new created task's name

[Expected result]:
- [step 5 and step 6] The task's name is properly displayed, before and after the task was saved

[Actual result]:
- [step 5] Some characters are cut off in the Subject section (the most visible one is "g")

[Regression range]:
- The issue is not a recent regression, as it is reproducible all the way back to 29.0a1 (2014-01-03)

[Additional notes]:
- The characters are fully visible in the Subject section if using Google Chrome
For those who don't have Outlook credentials to try reproducing this, could you attach a screenshot, please?
(In reply to Jonathan Kew (:jfkthame) from comment #1)
> For those who don't have Outlook credentials to try reproducing this, could
> you attach a screenshot, please?

Sure! Here is a screencast where the issue is visible https://goo.gl/nsoFUS.
This issue is reproduced using https://calendar.google.com/ link and create an event, on Ubuntu 14.04 x64. Note that in Google Chrome is the same behaviour in this case.
I think this is essentially the same issue as discussed in bug 1404442, where the <input> element has a line-height and height that aren't really sufficient for the font being used, and if the glyphs have descenders that extend into the padding at the bottom of the <input>, they get clipped.
Is this still an issue, or has it been resolved (by bug 752790, perhaps)?
Flags: needinfo?(iulia.cristescu)
(In reply to Jonathan Kew (:jfkthame) from comment #6)
> Is this still an issue, or has it been resolved (by bug 752790, perhaps)?

Sorry for the late reply! 
I can confirm that the issue is not reproducible anymore on 62.0a1 (2018-05-14), 61.0b5 (20180514150347) and 60.0 build2 (20180503143129) across platforms.
Flags: needinfo?(iulia.cristescu)
Also, 59.0.2 (20180323154952) is not affected anymore.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.