Closed Bug 1403188 Opened 2 years ago Closed 2 years ago

Migrate browser_console_private_browsing.js to the new console

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(firefox61 fixed)

RESOLVED FIXED
Firefox 61
Tracking Status
firefox61 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(1 file)

No description provided.
Priority: -- → P3
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Assignee: nchevobbe → nobody
Status: ASSIGNED → NEW
Depends on: 1362023
Priority: P3 → P2
Whiteboard: [newconsole-mvp]
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Priority: P2 → P1
Depends on: 1307928
Depends on: 1443079
No longer depends on: 1362023
Sorry this is not the most readable review :/
Hope it's clear enough though
Comment on attachment 8959604 [details]
Bug 1403188 - Enable browser_console_webconsole_private_browsing.js in new console frontend; .

https://reviewboard.mozilla.org/r/228418/#review234344

Looks good! Thanks a lot for migrating this complex test.

::: devtools/client/webconsole/new-console-output/test/mochitest/browser_console_webconsole_private_browsing.js:35
(Diff revision 1)
> -      BrowserTestUtils.addTab(gBrowser, "data:text/html;charset=utf8," +
> -                                        "<p>hello world! I am not private!");
> -    gBrowser.selectedBrowser.addEventListener("load", onLoadTab, true);
> -  }
> -
> -  function onLoadTab() {
> +add_task(async function() {
> +  await addTab(NON_PRIVATE_TEST_URI);
> +
> +  // On e10s, the exception is triggered in child process and is ignored by test harness.
> +  if (!Services.appinfo.browserTabsRemoteAutostart) {
> +    expectUncaughtException();

Test fails with --disable-e10s for me. Since we wrap the exception, I don't think we should expect uncaught exception here?
Attachment #8959604 - Flags: review?(jdescottes) → review+
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b801fbf9bc4
Enable browser_console_webconsole_private_browsing.js in new console frontend; r=jdescottes.
https://hg.mozilla.org/mozilla-central/rev/7b801fbf9bc4
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Product: Firefox → DevTools
Duplicate of this bug: 1243960
You need to log in before you can comment on or make changes to this bug.