Enter key no longer works in the address bar after you use "Paste & Go" in different tab

RESOLVED WORKSFORME

Status

()

defect
P2
normal
RESOLVED WORKSFORME
2 years ago
Last year

People

(Reporter: mcoman, Unassigned)

Tracking

(Blocks 1 bug, {regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 wontfix, firefox-esr60 wontfix, firefox55 wontfix, firefox56 wontfix, firefox57 wontfix, firefox58 wontfix, firefox59 wontfix, firefox60 wontfix, firefox61 wontfix, firefox62 unaffected)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

Posted image address bar.gif
Affected versions:
- Firefox Release 55.0.3
- Firefox Beta 57.0b3
- Nightly 58.0a1

Affected Platforms:
- All Windows
- All Mac
- All Linux

Steps to reproduce:
1. Copy string "http://example.org/"
2. Open the browser and navigate to "about:newtab".
3. Paste the copied string in the address bar (do not navigate to the example website).
4. Open a new tab, right click on the address bar and select "Paste & Go" option.
5. Return to the first tab and press the "Enter" key.
6. Observe the browser behavior

Expected result:
- The "http://example.org/" website is opened.

Actual result:
- Nothing happens.

Regression window:
Last good revision: edfff7a9e4c43f6d516dfbf69a64e205e5cdb699 (2016-09-16)
First bad revision: b401cb17167b34c362eb819259effbb3c0979f59 (2016-09-17)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=edfff7a9e4c43f6d516dfbf69a64e205e5cdb699&tochange=b401cb17167b34c362eb819259effbb3c0979f59

From the pushlog it seems that the bug 1301093 stands out.

Notes:
- Attached a screen recording of the issue.
I'd not call it P1, due to the complex requirements (text "forgotten" in a tab, paste & go). I don't know if this may be hit often in the wild, I'm assuming not. P2 because it's a regression, it's actually a P2.5 imo, if that would exist!

On the other side, I've seem some reports from users about Enter doing nothing, and this may be one of those cases. Something to keep in mind.
Flags: needinfo?(mak77)
Priority: -- → P2
Whiteboard: [fxsearch]
Marius, this is working for me on latest nightly. Could you try it and see if it works for you now?

There's been a few changes recently, and I think one of them (possibly bug 1446551) might have fixed it.
Flags: needinfo?(marius.coman)
I have retested this issue and it is no longer reproducible. Now the "Enter" key works in the address bar after you use "Paste & Go" in different tab.
Verified on Windows 10 x64, Arch Linux and Mac 10.13 with the latest Firefox release (61.0), Firefox Beta (62.0b3) and Nightly (63.0a1).
Considering the this, using the mozregression tool I tried to find what fixed the issue:

First good revision: 291a11111bdd05c5cd55dd552da4b1285ceba9b2 (2017-05-24)
Last bad revision: 5bc1c758ab57c1885dceab4e7837e58af27b998c (2017-05-23)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5bc1c758ab57c1885dceab4e7837e58af27b998c&tochange=291a11111bdd05c5cd55dd552da4b1285ceba9b2

It's unclear to me which bug from the pushlog fixed this.

Considering the above I am closing this issue.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(marius.coman)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.