Moving [Bookmarks Toolbar Items] toolbaritem to the navbar, ends up in the overflow menu

RESOLVED DUPLICATE of bug 1421021

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1421021
2 years ago
Last year

People

(Reporter: zombie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Noting this down even if it's not reliably reproducible. :\

This is not an issue of space, I have only a few bookmarks/folders there, and have been using this configuration for years.

On today's Beta/57, I go to customize mode, click reset to defaults, and drag the [Bookmarks Toolbar Items] thingie from the bookmark toolbar to the right of the urlbar, it goes into overflow menu upon exiting customize mode (but not if I move it to the left of the urlbar), regardless of the window size.

Opening a new window makes the problem go away, and restarting sometimes does as well.
Just for clarity, what OS and what window density (compact, normal, touch) are you using? I assume you can't reproduce with a clean profile? Can you still reproduce if you re-title the bookmarks that are immediate children of the bookmarks toolbar to single-letter things (A, B, C, etc.) ?
Flags: needinfo?(tomica)
Summary: Moving [Bookmarks Toolbar Items] thingie to the navbar, ends up in the overflow menu → Moving [Bookmarks Toolbar Items] toolbaritem to the navbar, ends up in the overflow menu
This is on Windows 7, in normal and I think also compact mode before I first clicked reset (as that was my setting before 57, not sure if it was persisted).

And they already are two/three letter acronyms.
Flags: needinfo?(tomica)
(In reply to Tomislav Jovanovic :zombie from comment #2)
> This is on Windows 7, in normal and I think also compact mode before I first
> clicked reset (as that was my setting before 57, not sure if it was
> persisted).
> 
> And they already are two/three letter acronyms.

In that case, can you reproduce if you create a clean profile with the same number of bookmarks with titles of the same length?
Flags: needinfo?(tomica)
Posted image bookmark-navbar.png
Sorry for the delay, I tried to narrow this to something reliably reproducible, but I'm couldn't.

I did actually reproduce in 58 nightly (fairly clean profile) with the configuration as shown in the attachment (very close to my original configuration in beta), but again, not reliably.
Flags: needinfo?(tomica)
Component: Theme → Toolbars and Customization
Priority: -- → P5
See Also: → 1111986
See Also: → 1421021
This bug happens very often in Beta 59 with a normal usage. Moving an extension icon behind the Overflow menu can activate the bug. The only way to fix it is to restart the browser.
This might also be related to another bug where all except the furthest left bookmarks disappear. Clicking Overflow icon highlights the button but nothing happens. The only way to close Firefox is by terminating it through Task Manager.
Some screenshots to illustrate how I was able to reproduce this bug consistently.
Let's dupe to a bug that has good STR.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
See Also: 1421021
Duplicate of bug: 1421021
See Also: 1111986
You need to log in before you can comment on or make changes to this bug.