Closed Bug 140333 Opened 19 years ago Closed 19 years ago

Enable preference for Reply-To in mail lists

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: sgala, Assigned: sspitzer)

Details

There is a long debate about wether listservers should munge headers or not.

The result is that roughly 50% of lists do this, and the rest don't.

It would be great to have a preference for the client selecting (on reply) which
kind of reply is really intended.

In my case I want that lists that don't munge headers are replied by default,
but for other users the opposite would be true. This preference would help to
alleviate confusion when people is subscribed to several lists, some which munge
headers and some that do not.

Also, I think there are specific headers for listserver, so messages coming from
lists would be easily selectable. In general, automatic filters would also bre
great, but this is another story :-).

Reply-All would retain the current behaviour.

This (I think) is available in preferences in other mail agents.
I'm not entirely sure I understand what this RFE is about...

Reporter: Can you give a detailed description of what you would like the
behavior of this pref to be?
I would like that:

Precondition: the mail client can detect if the user is replying to a list
- if the pref is set, reply action would reply to the list, while reply-all
would reply to the list *and* other people in headers
- if the pref is not set, reply action would have the current behaviour

This could be summarise as:
- ignore Reply-To: when replying to lists and pref is set, and reply to list
- honor all headers when pref is not set


The idea is that the user can safely assume that all the subscribed lists munge
a specific Reply-To: header or not.

References:

http://www.metasystema.org/essays/reply-to-useful.mhtml (one way)
http://www.unicom.com/pw/reply-to-harmful.html (other way)

Currently (and this is not a fault of Mozilla, rather of list handlers), the
user has to be very careful to look what Reply-to: means, because some list
manager software put a specific Reply-To: to the list, while others don't.

There is a long debate whether this should be done or not (at the list manager
level), with roughly 50% of people on each side. This results in lists that have
completely different behaviour, which poses usability issues.

So basically you want a pref which, if it detects that a message came from a
mailing list, makes the Reply button send the reply to the list regardless of
whether there's a Reply-To or not?

With this pref, how will the user be able specify to either reply to the list or
to the sender on a per-message basis (without editing the To: lines manually)?

This pref would make the Reply button for mailing lists act like the Reply
button in newsgroups. Consistency between lists and groups are a good thing, but
the fact that the Reply button in newsgroups sends the reply to the group is a
bug (95623).

In my opinion, the best solution would be to add a separate followup button
which does a reply to recipients but not to sender. The reply button would
retain it's current behavior. I've filed bug 144914 for this.

What do you think of this solution? Would you still want this pref?
>With this pref, how will the user be able specify to either reply to the list or
>to the sender on a per-message basis (without editing the To: lines manually)?

Currently I need to hand edit To: lines for each message I send to a few lists,
so for me it would not be that bad. But...

>In my opinion, the best solution would be to add a separate followup button
>which does a reply to recipients but not to sender. The reply button would
>retain it's current behavior. I've filed bug 144914 for this.

This does not look the same I'm looking for, as (see example below) it would
send several copies on lists that don't munge headers. The common behaviour on
such lists is that the replier replies-all, so the number of people in the
addressing list increases as the thread goes on. If the user forgets to
reply-all, then the message is *only* sent to the From: person, and the
collaboration suffers.

For me, the common use case is reply-all to mail (just reply sometimes) and
follow-up for lists. Some lists (most Jakarta Apache ones) have a Reply-To to
the list, so reply works. Other lists I'm subscribed don't, and this brings my
problems remembering where am I or looking at headers to find that half of my
answer must be copied to a new message and draft discarded, or hand editing all
the to: and cc: headers...

Testing your idea, I found something funny (Mozilla 1.0RC2)

Fragment of MIME headers (names hidden):

Reply-To: jetspeed-user@jakarta.apache.org
Delivered-To: mailing list jetspeed-user@jakarta.apache.org
Received: (qmail 84073 invoked from network); 4 Jul 2001 05:54:15 -0000
Message-ID: <02b901c1044d$a2ebf490$353cf835@blah.company1.com>
Reply-To: "Guy One" <guy_one@company1.com>
From: "Guy One" <guy_one@blah.company1.com>
To: <jetspeed-user@jakarta.apache.org>, <guy_two@company2.com>,
   <guy_three@company3.com>

Reply: goes to jetspeed-users (only first encountered Reply-To: header)
Reply-All: goes to all of the To: people, not the From: one

Is it a bug? None of the buttons would send to the "Guy One".

How would this message behave under your proposal? I would like a preference for
sending *just* to the list on follow-up(lists), and do Reply-All on non-list
messages. In this way, the(my) common use case would allow me to treat uniformly
my replies. This preference could be handled for the follow-up button, instead
of the Reply, as follow-up is conceptually more flexible than reply (after all,
following up a discussion means posting it to the list, *not* replying to the
sender or just receivers when the list is not amongst them, while in private
exchanges follow-up means replying to everybody).

I know, life is not easy :-) But such a RFE should be checked with the way most
listmanagers handle headers currently to ensure that it will perform as
expected. I gave you just one example.
> This does not look the same I'm looking for, as (see example below) it would
> send several copies on lists that don't munge headers. The common behaviour on
> such lists is that the replier replies-all, so the number of people in the
> addressing list increases as the thread goes on. If the user forgets to
> reply-all, then the message is *only* sent to the From: person, and the
> collaboration suffers.

The common behavior which you describe is that when a message is sent to a
mailing list with headers like this:

From: someuser@example.com
To: thelist@example.net

...and otheruser@example.org does a Reply All, both the list and
someuser@example.com gets the reply (so someuser@example.com gets it twice). If
someone does a Reply All to that message, both someuser@example.com and
otheruser@example.org would get it twice, and so on.

That common behavior is what I want bug 144914 to prevent. If everyone used bug
144914's Followup feature (Reply All Except Sender), each of the replies would
only go to the list.

> For me, the common use case is reply-all to mail (just reply sometimes) and
> follow-up for lists. Some lists (most Jakarta Apache ones) have a Reply-To to
> the list, so reply works.

...but the Reply-To munging prevents you from replying only to the sender
without editing To:/Cc: headers manually. If bug 144914 is implemented, and
other mail clients implement the same feature (some already has), there would be
no need for mailing lists to do Reply-To munging, and the user would be able to
choose for each message with a click on a button (or the stroke of a key)
whether to reply privately or to the list. That /would/ make life easy :-)

> Other lists I'm subscribed don't, and this brings my
> problems remembering where am I or looking at headers to find that half of my
> answer must be copied to a new message and draft discarded, or hand editing all
> the to: and cc: headers...

Well, you wouldn't need to do that if bug 144914 was implemented. You'd have a
button which you could use for /all/ mailing lists, Reply-To munging or not,
which would reply only to the list(s) and other (non-list members) who were CC'ed.

Basically, what I'm saying is that instead of a pref which will turn Reply in to
a followup button (this is how I understand this RFE; please correct me if I'm
wrong), let's keep Reply for replying privately (this is how it will behave in
newsgroups as well once bug 95623 is fixed) and add a separate Followup button
which will reply to the To: and Cc: list but *not* to the From: address.

> Testing your idea, I found something funny (Mozilla 1.0RC2)
[...]
> Reply: goes to jetspeed-users (only first encountered Reply-To: header)
> Reply-All: goes to all of the To: people, not the From: one
>
> Is it a bug? None of the buttons would send to the "Guy One".

Yes, that seems like a bug. Since there is an additional Reply-To header which
points to Guy One, both Reply and Reply All should go to him as well. Please
file this bug if you are unable to find an existing report. (Note, however, that
if there was only the first Reply-To header (the one pointing to the list), even
Reply All wouldn't include the sender; this is another downside of Reply-To
munging).

> How would this message behave under your proposal?

Reply and Reply All would behave as they currently do (except for, of course,
that the bug about missing the second Reply-To header should be fixed).
Followup, or whatever the new button will be called, would go to jetspeed-user,
Guy Two, and Guy Three, which is very reasonable IMO since Guy Two and Guy Three
is likely to not be subscribed to the list, as there would otherwise be no point
in listing them separately in the To header. (The fact that many messages
currently distributed through mailing list has the list members whose message
the message is a followup to listed in To: or Cc: is an error which originates
from the fact that most current mail clients lack a followup button.)

So, have I convinced you yet? :-)
I wrote:
> Yes, that seems like a bug. Since there is an additional Reply-To header which
> points to Guy One, both Reply and Reply All should go to him as well.

I was wrong -- as it was pointed out to you in bug 106189 comment 6, emails are
only allowed to contain a single Reply-To header.
Yup, I have chosen a bad example. I have replied there.

>So, have I convinced you yet? :-)

Yes, you have. :-)

In fact, both Guy two and Guy three are committers in the project, and members 
of the list. They went to the list because people often Reply-All: just in case.

Please, close this one, and try to have nice list features for the agent in the
new bug. Thanks for your effort.
Thanks for the interesting debate, Santiago. (And for the bug report -- keep 'em
coming.)

Marking WONTFIX based on reporter's comment 7.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
Verifying as WONTFIX.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.