Extension popups in the overflow menu are cropped from the bottom

VERIFIED FIXED in Firefox 57

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: MikkCZ, Assigned: mikedeboer)

Tracking

57 Branch
Firefox 58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 unaffected, firefox57 verified, firefox58 verified)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(2 attachments)

Posted image screenshot
Spotted on macOS Yosemite with Firefox 57.0b3.

STR:
1. Run Firefox.
2. Install e.g. uBlock origin.
3. Pin the add-on icon to the overflow menu.
4. Open the overflow menu.
5. Click the uBlock origin item.
6. The opened popup has blank space on the bottom overlapping the extension popup.

The customize toolbars footer is not hidden (only its text).
Note this does not happen for the system icon, like library.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1402845

Comment 3

2 years ago
Reopening this because content is actually cut off here, and that's not what got reported in bug 1402845.

I can't reproduce this, though it's clear that other people can, cf. bug 1406029.

Can you find better STR? I see content being cut off (with the steps from bug 1406029), but not this light-grey bar at the bottom. On Windows, I can't reproduce any issues with uBO. :-\
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

2 years ago
Depends on: 1402845

Comment 4

2 years ago
Ni for comment #3.
Flags: needinfo?(mstanke)
Whiteboard: [photon-structure][triage]
These STR are the best I have. During a workshop yesterday, I have reprorduced this with 6 more people and used this bug to demonstrate mozregression. I will add the found regression window once I get back go my computer in an hour or so.

Note this does not affect uBO only, the same happens with Niobium Password Generator too.
It's reproducible on Mac OS X and Fedora, but I think during the workshop people saw it on Windows too.

But I guess it happens only when the opened popup resizes (is created dynamically by JavaScript) or is bigger than the overflow menu popup, because for example Nightly Tester Tools WebExtension popup (which is small) is not affected.

Comment 8

2 years ago
I could reproduce with uBlock origin 1.14.14 and Nightly.

Using the browser toolbox.

The stack element, a direct child of the panelview element, and which contains the extension popup panel, has a height of 386px. This is correct.

However, the panelview parent element has a max-height of 386px. This is incorrect, since this does not account for the box.panel-header element, another child of the panelview element. The incorrectly cropped height seems to match the height of the panel header. It seems to me the fix is simply to take into account the panel header height when setting the max-height style of the panelview element -- or maybe more generally the sum of the height of all direct children of the panelview element.

Updated

2 years ago
Blocks: 1374749
Comment hidden (mozreview-request)
Assignee

Updated

2 years ago
Assignee: nobody → mdeboer
Status: REOPENED → ASSIGNED
Priority: -- → P1
Whiteboard: [photon-structure][triage] → [photon-structure]

Comment 10

2 years ago
mozreview-review
Comment on attachment 8916682 [details]
Bug 1403466 - Don't set a max-height on panelviews used by WebExtensions, because it causes browser contents to be cut-off.

https://reviewboard.mozilla.org/r/187772/#review192826
Attachment #8916682 - Flags: review?(gijskruitbosch+bugs) → review+
Whiteboard: [photon-structure] → [reserve-photon-structure]

Updated

2 years ago
Depends on: 1406031

Comment 12

2 years ago
hg error in cmd: hg rebase -s 25f7ed092e34 -d e3f39de40209: abort: can't rebase public changeset 25f7ed092e34
(see 'hg help phases' for details)
Comment hidden (mozreview-request)

Comment 14

2 years ago
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cd62fb50fe61
Don't set a max-height on panelviews used by WebExtensions, because it causes browser contents to be cut-off. r=Gijs
Duplicate of this bug: 1406031
Duplicate of this bug: 1406029
Blocks: 1402845
No longer depends on: 1402845
https://hg.mozilla.org/mozilla-central/rev/cd62fb50fe61
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Assignee

Comment 18

2 years ago
Comment on attachment 8916682 [details]
Bug 1403466 - Don't set a max-height on panelviews used by WebExtensions, because it causes browser contents to be cut-off.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1374749, buggy WebExtension panel sizing code.
[User impact if declined]: The panel will be shown too small to be able to accommodate the full height requested by the extension, causing it to look cut off.
[Is this code covered by automated tests?]: yes, no regressions in panel sizing code found.
[Has the fix been verified in Nightly?]: No.
[Needs manual test from QE? If yes, steps to reproduce]: Yes, STR can be found in comment 0.
[List of other uplifts needed for the feature/fix]: n/a.
[Is the change risky?]: Minor risk.
[Why is the change risky/not risky?]: Because the patch/ fix is isolated to WebExtension panel handling code and doesn't touch other areas.
[String changes made/needed]: n/a.
Attachment #8916682 - Flags: approval-mozilla-beta?
I can verify this as working in Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0 ID:20171010220102.
Status: RESOLVED → VERIFIED
Comment on attachment 8916682 [details]
Bug 1403466 - Don't set a max-height on panelviews used by WebExtensions, because it causes browser contents to be cut-off.

Photon polish, Beta57+
Attachment #8916682 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I have reproduced the issue mentioned in comment 0 using an affected Firefox 58.0a1 build (BuildId:20170927100120).

I have verified that the issue is not reproducible using Firefox 57.0b8 (Build Id:20171009192146) on Windows 10 64bit, macOS 10.11.6 and Ubuntu 16.04 64bit.
You need to log in before you can comment on or make changes to this bug.