Bookmarks toolbar doesn't use regular favicons

RESOLVED FIXED

Status

()

P2
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: francois, Unassigned)

Tracking

({nightly-community})

Trunk
nightly-community
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 wontfix, firefox58 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Posted image Capture.PNG
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20170926220106

Steps to reproduce:

Add bookmark (with a favicon) to bookmarks toolbar


Actual results:

Bookmarks toolbar doesn't seems to always use 'rel="icon"' for the favicon. For some websites, 'apple-touch-icon' are shown.
A similar issue as been fixed for tabs icons (https://bugzilla.mozilla.org/show_bug.cgi?id=1401777).
Blocks: 1401777
Status: UNCONFIRMED → NEW
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: --- → affected
status-firefox58: --- → affected
status-firefox-esr52: --- → unaffected
Ever confirmed: true
Keywords: nightly-community
This is known and we don't plan to fix it for 57 since the changes are not safe enough for it.
status-firefox57: affected → wontfix
Depends on: 1347532
Component: Untriaged → Bookmarks & History
Priority: -- → P2
this is not actually a regression of bug 1401777, it's an expected regression of bug 1352459
Blocks: 1352459
No longer blocks: 1401777

Comment 3

2 years ago
I suppose what would help this is if site developers used the same icon image but different sizes.  With some blogs, such http://eq2wire.com/ the favicon.ico is a microphone image which the tab has and the bookmark gets the apple_touch_icon.png which is the standard WordPress icon.

On most of my sites I just have a single 16x16 favicon.ico in the root directory.  Anyway, is kind of annoying.
it's not necessary, the browser must be able to pick the best icon for the resolution it needs.
Also just having a single 16x16 icon is wrong, because on a double-dpi monitor you want to have a 32x32 icon at least.
The regression where we always picked the biggest icon has been fixed in Nightly, I verified the twitter and gitlab icons are now ok.

There are still some edge cases where we don't pick a good 32px image that we'll handle in bug 1403829, but for the most part this is fixed.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.