Closed Bug 1403658 Opened 3 years ago Closed 3 years ago

Add nsString overload for HTMLAnchorElement::GetName() and HTMLBodyElement::GetBackground(), add HTMLBodyElement::FromContentOrNull() - use those in Thunderbird

Categories

(Core :: DOM: Core & HTML, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: jorgk-bmo, Assigned: jorgk-bmo)

Details

Attachments

(2 files)

Add nsString overload for HTMLAnchorElement::GetName() and HTMLBodyElement::GetBackground(), add HTMLBodyElement::FromContentOrNull().

These are bits that are missing and should be added for completeness.

They are also needed for Thunderbird.
Priority: -- → P3
Fairly trivial review, I hope you don't mind.
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8916618 - Flags: review?(bzbarsky)
Comment on attachment 8916619 [details] [diff] [review]
M-C part: 1403658-FromContentOrNull.patch (v1)

r=me
Attachment #8916619 - Flags: review?(bzbarsky) → review+
Comment on attachment 8916618 [details] [diff] [review]
C-C part: 1403658-FromContentOrNull.patch (v1)

r=me.  Thank you for following up on this!
Attachment #8916618 - Flags: review?(bzbarsky) → review+
Hi Boris, thanks for the review. I would have followed up earlier, but I had to fight some bustage in TB caused by Necko changes.

Hi Sheriff, please land the M-C part only.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/138467b4e1d2
Add nsString overload for HTMLAnchorElement::GetName() and HTMLBodyElement::GetBackground(), add HTMLBodyElement::FromContentOrNull(). r=bz
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/138467b4e1d2
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/9f4da17feaf2
Use nsString overload of HTMLAnchorElement::GetName() and HTMLBodyElement::GetBackground(), use HTMLBodyElement::FromContentOrNull(). r=bz
Summary: Add nsString overload for HTMLAnchorElement::GetName() and HTMLBodyElement::GetBackground(), add HTMLBodyElement::FromContentOrNull() → Add nsString overload for HTMLAnchorElement::GetName() and HTMLBodyElement::GetBackground(), add HTMLBodyElement::FromContentOrNull() - use those in Thunderbird
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.