Moz crashes when returning to page via back

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
--
critical
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Brad, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020417
BuildID:    2002041707

The browser crashes.  Kaput.  Very annoying.

Reproducible: Always
Steps to Reproduce:
1.Goto http://www.netmeister.org/news/usenet/footnode.html
2.From the topline of this page copy and paste dennis ritchie's webpage into the
browser and go there
3.hit the back button
4.BOOM!

Actual Results:  It crashed!

Expected Results:  To view the page in question.

Comment 1

16 years ago
Not crashing with linux 2002042509 1.0.0 branch. Do you use a special sort of
copy and paste? Anything else special? Did talkback fire up?
(Reporter)

Comment 2

16 years ago
No, nothing special (I used the mouse entirely). 
 
I went to the above URL.  I then pasted Dennis Ritchie's page into the url 
window using only the mouse.  Pressed enter (taking me to Dennis Ritchie's 
page), and then hit back.  Crash.  Would you like me to get today's a more 
recent build and try that?  If so, please specify build (I presume you'll want 
me to get the nightly, but just to be safe). 

Comment 3

16 years ago
trying a newer build certainly wouldn't hurt.
http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/
(make sure to get a talkback build)

if you have a talkback ID for the crash with 20020417, that would be helpful too.
(Reporter)

Comment 4

16 years ago
 Don't know what a talkback Id is, BUT, I do have a core file.  Several of them 
actual, and can make one extra special just for you :). 
 
  I'll hold off trying on a new build, until you let me know about the core 
file (as when I install the new nightly, I will probably need to delete my 
current build). 
  
 
 
(Reporter)

Comment 5

16 years ago
To add to this, I have gdb and would happily run a stack trace for you.  
Anything more invasive than that, and I'd rather just forward the corefile to 
you (its about 2 meg). 
(Reporter)

Comment 6

16 years ago
I am uncomfortable running the talkback builds due to privacy concerns.  If we 
determine that I absolutely need to do that, I will, but I honestly prefer not 
to.  I know its annoying, but that kind of stuff worries me a bit. 

Comment 7

16 years ago
if you can get a real stack (as opposed to a bunch of "no symbols" or "???") out
of the core file that would at least help to identify what component this should
be in.  The stack trace is the main thing to get from the talkback info.

you have the opportunity to select what you do and don't send in the talkback
report...
(Reporter)

Comment 8

16 years ago
Blech, you were right gdb is useless (didn't realize you guys were stripping 
the nightlies). 
 
At any rate, good news.  With the latest build 2002042610, I cannot reproduce 
the bug.  Sorry about the annoyance, and glad you guys were so helpful and 
pleasant to deal with. 
 
Kudos on the excellent browser btw.  Go ahead and mark this one invalid I 
think, and I'm sorry to have interfered with your Friday night. 

Comment 9

16 years ago
no prob

marking WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.