Closed Bug 1403665 Opened 2 years ago Closed 2 years ago

Exclude " and ? from download filenames

Categories

(Firefox :: Screenshots, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: ianbicking, Assigned: ianbicking)

Details

Attachments

(1 file)

No version update for this, we're going to import several small bugs (in parallel) and then bump the version.

This is the fix for this bug: https://github.com/mozilla-services/screenshots/issues/3517

And is an export of this commit: https://github.com/mozilla-services/screenshots/pull/3524/commits/42a561d6ad6e160628344d271f9244df5179e8e0
Attachment #8912828 - Flags: review?(kmaglione+bmo)
Comment on attachment 8912828 [details]
Bug 1403665 - remove " and ? from filenames

https://reviewboard.mozilla.org/r/184132/#review191200
Attachment #8912828 - Flags: review?(kmaglione+bmo) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4bf4766d914b
remove " and ? from filenames r=kmag
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4bf4766d914b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8912828 [details]
Bug 1403665 - remove " and ? from filenames

Approval Request Comment
[Feature/Bug causing the regression]:
https://github.com/mozilla-services/screenshots/issues/3517 – download on Windows would not work when a page contains " or ? in the title

[User impact if declined]:
Windows users on some pages get an error message trying to download screenshots

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
No

[Needs manual test from QE? If yes, steps to reproduce]: 
To reproduce on Windows:
1. Open https://www.heise.de/forum/heise-online/News-Kommentare/Gefaehrdeter-Datenschutz-Firefox-loescht-lokale-Datenbanken-nicht/Re-Dessen-neue-Bedienoberflaeche-Photon/posting-31065842/show/
2. Begin a screenshot
3. Make a selection or click on Save Visible
4. Click the down arrow to download the shot
5. It should work as expected, without error messages

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
Small extension to existing code

[String changes made/needed]:
None
Attachment #8912828 - Flags: approval-mozilla-beta?
Flags: needinfo?(cosmin.muntean)
Will wait for the Nightly verification before taking this in Beta57.
I have retested this issue on latest Nightly (58.0a1, Build ID: 20171004220309)(x64 and x32) and the issue is no longer reproducible.
I can confirm that the issue was reproducible on older Nightly builds (eg: build from 2017-10-01).

Verified as fixed on Windows 10 x64, Windows 7 x64, Mac OS 10.12 and Ubuntu 14.04 x64 using latest Nightly (58.0a1) build.
Flags: needinfo?(cosmin.muntean)
Comment on attachment 8912828 [details]
Bug 1403665 - remove " and ? from filenames

Screenshots related, recent regression, Beta57+
Attachment #8912828 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Managed to reproduce the initial issue on 58.0a1 (2017-09-27). I can confirm that 57.0b7 build1 (20171009192146) is verified fixed, using Windows 10 x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.