[macOS] Backspace key should remove composing Hangul character rather than committing it

RESOLVED FIXED in Firefox 59

Status

()

defect
P3
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: chanil1218, Assigned: masayuki)

Tracking

({inputmethod})

57 Branch
mozilla59
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(3 attachments)

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170925150345

Steps to reproduce:

* Cmd+L to locate search field
* Enter Korean character(ㄱ)
* Click delete


Actual results:

Instead of delete chacter quickly, just remove focus. 


Expected results:

Delete focused character.

Updated

2 years ago
Component: Untriaged → Address Bar
Masayuki, is this a dupe of bug 1400189?
Flags: needinfo?(masayuki)
Perhaps, yes. But I'm not sure about "just remove focus" since I don't see any reaction when I press delete key in URL bar.
Flags: needinfo?(masayuki)
Reporter

Comment 3

2 years ago
I mean "just remove focus" is that underline shown below "ㄱ" disappeared instead of removing "ㄱ". 
I'm using Mac FYI.
Thanks. Do you still reproduce this bug with Beta 57 b5 or Nightly?
Flags: needinfo?(chanil1218)
Reporter

Comment 5

2 years ago
I pressed delete button firstly and later pressed delete button again. 
I tested this on 57.0b6
In Chrome deletion happens in single delete press.
Flags: needinfo?(chanil1218)
masayuki-san, what's the next step here?
Flags: needinfo?(masayuki)
Please keep waiting. I'm working on some regression bugs related to nsINode::GetChildAt(). I'll be back here when I get a chance.
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
Summary: Korean deletion delay → [macOS] Backspace key should remove composing Hangul character rather than committing it
Component: Address Bar → Widget: Cocoa
Flags: needinfo?(masayuki)
Keywords: inputmethod
Product: Firefox → Core

Updated

2 years ago
Priority: -- → P3
This is another case of bug 1358958. Korean IME started to commit composition and send deleteBackward command when user presses Backspace key during composition.
Assignee: nobody → masayuki
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(masayuki)
See Also: → 1358958
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
While composing Korean IME, other control keys like arrow keys causes committing composing Hangul character and should work as usual.  However, on Gecko, they cause only committing composing Hangul character because Gecko ignores following commands came from Korean IME.

So, the patches make ChildView and TextInputHandler handle such commands as usual.  Note that, there are some other commands which are not included in the patches, but our editor doesn't support the commands even with different key combination.  So, the commands included in the patches are enough for current implementation.

Comment 15

2 years ago
mozreview-review
Comment on attachment 8934056 [details]
Bug 1403759 - part 1: Make TextInputHandler::InsertNewline() treat other commands

https://reviewboard.mozilla.org/r/204796/#review210832
Attachment #8934056 - Flags: review?(m_kato) → review+

Comment 16

2 years ago
mozreview-review
Comment on attachment 8934057 [details]
Bug 1403759 - part 2: Handle edit/selection commands like insertNewline: in TextInputHandler::HandleCommand()

https://reviewboard.mozilla.org/r/204798/#review210844
Attachment #8934057 - Flags: review?(m_kato) → review+

Comment 17

2 years ago
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/f5039cf4ead7
part 1: Make TextInputHandler::InsertNewline() treat other commands r=m_kato
https://hg.mozilla.org/integration/autoland/rev/afc17c7465c2
part 2: Handle edit/selection commands like insertNewline: in TextInputHandler::HandleCommand() r=m_kato

Comment 18

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f5039cf4ead7
https://hg.mozilla.org/mozilla-central/rev/afc17c7465c2
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.