Closed Bug 1403893 Opened 3 years ago Closed 10 months ago

toolkit crashreport mips

Categories

(Toolkit :: Crash Reporting, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: qiaopengcheng-hf, Assigned: qiaopengcheng-hf)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux mips64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170927142759

Steps to reproduce:

The function

vector<string> DwarfCFIToModule::RegisterNames::MIPS()

within file

toolkit/crashreporter/google-breakpad/src/common/dwarf_cfi_to_module.cc



Actual results:


toolkit/crashreporter/google-breakpad/src/common/dwarf_cfi_to_module.cc


vector<string> DwarfCFIToModule::RegisterNames::MIPS()

missing  fpu register  $f1.


Expected results:

including all mips fpu register.
Attachment #8913186 - Flags: review?(sledru)
Attachment #8913186 - Flags: review?(n.nethercote)
Attachment #8913186 - Flags: review?(mstange)
Attachment #8913186 - Flags: review?(jvarga)
Attachment #8913186 - Flags: review?(bzbarsky)
Comment on attachment 8913186 [details] [diff] [review]
Bug-1403893-toolkit-crashreport-misses-the-fpu-register  $f1

Please select only one reviewer, no need to ask 5 people.
Attachment #8913186 - Flags: review?(sledru)
Attachment #8913186 - Flags: review?(mstange)
Attachment #8913186 - Flags: review?(jvarga)
Attachment #8913186 - Flags: review?(bzbarsky)
Assignee: nobody → qiaopengcheng-hf
(In reply to Sylvestre Ledru [:sylvestre] from comment #2)
> Comment on attachment 8913186 [details] [diff] [review]
> Bug-1403893-toolkit-crashreport-misses-the-fpu-register  $f1
> 
> Please select only one reviewer, no need to ask 5 people.


sorry!
Next time I'll pay attention.
Thank you!
Comment on attachment 8913186 [details] [diff] [review]
Bug-1403893-toolkit-crashreport-misses-the-fpu-register  $f1

Review of attachment 8913186 [details] [diff] [review]:
-----------------------------------------------------------------

I would normally re-route a crash reporter review to Ted. But he's away, and this is a trivial and obvious fix for a Tier-3 platform, so r=me.
Attachment #8913186 - Flags: review?(n.nethercote) → review+
Status: UNCONFIRMED → ASSIGNED
Component: Untriaged → Crash Reporting
Ever confirmed: true
Product: Firefox → Toolkit
This file comes from upstream Breakpad, so it needs to be fixed there:
https://chromium.googlesource.com/breakpad/breakpad/+/master/#to-request-change-review

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:qiaopengcheng-hf, could you have a look please?

Flags: needinfo?(qiaopengcheng-hf)

(In reply to Release mgmt bot [:sylvestre / :calixte] from comment #6)

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:qiaopengcheng-hf, could you have a look please?

Because the related files are third-part component. The origin repository is not mozilla.
But I don't know how to push up to the origin repository.

Flags: needinfo?(qiaopengcheng-hf)

It's a shame we haven't merged this patch yet, I will be landing this as part of our locally applied patches.

Pushed by gsvelto@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b80028b6b68
Make Breakpad print out the MIPS floating point registers correctly. r=froydnj
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.