Delete all the layers-full WR code

RESOLVED FIXED in Firefox 58

Status

()

enhancement
P1
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: kats, Assigned: kats)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Other Branch
mozilla58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 unaffected, firefox58 fixed)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(6 attachments)

Now that we have layers-free turned on by default we shouldn't need the old layers-full code any more, and should be able to delete it.
Whiteboard: [gfx-noted][wr-mvp][triage] → [wr-reserve] [gfx-noted]
Related: we should remove layers-free from about:config, no? It should be implied by webrender.
Yup. If I have a long build today I'll cook up a patch, should be trivial.
Picking this up since having extra unused codepaths makes it harder to follow the code flow.
Assignee: nobody → bugmail
I feel like this might rot bug 1391816 badly. Maybe it should wait for that to land?
Flags: needinfo?(bugmail)
Sure, I can rebase these on top of that once it lands.
Flags: needinfo?(bugmail)
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [wr-reserve] [gfx-noted] → [wr-mvp] [gfx-noted]
Depends on: 1391816
Comment on attachment 8913831 [details]
Bug 1403915 - Remove the layers-free pref entirely and assume it's true at the call sites.

https://reviewboard.mozilla.org/r/185206/#review191174
Attachment #8913831 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8913832 [details]
Bug 1403915 - Remove the IsLayersFreeTransaction() machinery and assume it's always true.

https://reviewboard.mozilla.org/r/185208/#review191176
Attachment #8913832 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8913833 [details]
Bug 1403915 - Remove the WebRender*Layer classes and functions that refer to them.

https://reviewboard.mozilla.org/r/185210/#review191178
Attachment #8913833 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8913834 [details]
Bug 1403915 - Remove some leftover painting callback goop.

https://reviewboard.mozilla.org/r/185212/#review191180
Attachment #8913834 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8914871 [details]
Bug 1403915 - Remove some leftover Layer-related goop.

https://reviewboard.mozilla.org/r/186136/#review191182
Attachment #8914871 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8914872 [details]
Bug 1403915 - Collapse EndTransactionInternal into EndTransactionWithoutLayers.

https://reviewboard.mozilla.org/r/186138/#review191184
Attachment #8914872 - Flags: review?(jmuizelaar) → review+
Showing some assertion failures because we're going down an unexpected codpeath. I filed bug 1405465 for handling it properly, and just inserted an early bailout in PresShell::Paint if we're using a WR layer manager. Hopefully that will fix it for now:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=51cb94c1f48525a2d1ada49bb6e3161d2d28c371
There's also a crash when we run the code to update canvases in empty transactions. I'm not really sure how to fix that, but I can comment it out and bump it to another bug as well. That code should not be running currently either so it shouldn't regress anything.
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5e0b4009cf4f
Remove the layers-free pref entirely and assume it's true at the call sites. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/0c0fcbab27d7
Remove the IsLayersFreeTransaction() machinery and assume it's always true. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/6268c4eadb5a
Remove the WebRender*Layer classes and functions that refer to them. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/6f9562da270e
Remove some leftover painting callback goop. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/f407f597b7bf
Remove some leftover Layer-related goop. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/87c152551a93
Collapse EndTransactionInternal into EndTransactionWithoutLayers. r=jrmuizel
Blocks: 1391816
No longer depends on: 1391816
Duplicate of this bug: 1382259
Depends on: 1452703
You need to log in before you can comment on or make changes to this bug.