The context menu is not dismissed when a tile is dragged

VERIFIED FIXED in Firefox 59

Status

()

defect
P3
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: cmuresan, Assigned: rrosario, Mentored)

Tracking

({good-first-bug, polish})

Trunk
Firefox 59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 wontfix, firefox58 wontfix, firefox59 verified)

Details

Attachments

(2 attachments)

[Affected versions]:
- Firefox 57 and up

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Start the browser and open a New Tab.
2. Click the context menu button for one of the tiles.
3. Drag a different tile and observe the context menu.
 
[Expected results]:
- The context menu is dismissed.

[Actual results]:
- The context menu stays in it's place.

[Notes]:
- Attached a screen recording of the issue.
Just following up here from my post on the GitHub issue (https://github.com/mozilla/activity-stream/issues/3624#issuecomment-350343893)! I'd love to tackle this bug if it's still available :)

Comment 2

a year ago
kunal12422 originally requested to work on this bug. k88hudson, is that still active or should Sean take this bug?
Mentor: khudson
Flags: needinfo?(khudson)
Keywords: good-first-bug

Updated

a year ago
Keywords: polish

Updated

a year ago
Depends on: 1402192
Fixed in https://github.com/mozilla/activity-stream/commit/313a951204c17c1c9a0b301dff3357d8e7c6d615
Assignee: nobody → rrosario
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(khudson)
Resolution: --- → FIXED

Updated

a year ago
Iteration: --- → 1.25

Updated

a year ago
Blocks: 1426774
The issue is still reproducible on the latest Nightly 59.0a1 (Build ID 20180110100224) on Arch Linux x64, Ubuntu 16.04 x86, Mac 10.12.6 and Windows 10 x64.
While the context menu is dismissed if you drag the same Top Site, it is not dismissed if you drag a different Top Site.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached a screen recording of the issue.

Updated

a year ago
Assignee: rrosario → nobody
No longer blocks: 1426774
Iteration: 1.25 → ---
No longer depends on: 1402192

Updated

a year ago
See Also: → 1430132

Comment 8

a year ago
I believe this was fixed by bug 1430132 (and that other bug was not actually fixed).
Assignee: nobody → rrosario
Blocks: 1431263
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → FIXED

Updated

a year ago
Target Milestone: Firefox 59 → ---

Comment 9

a year ago
https://hg.mozilla.org/mozilla-central/rev/8ae1faf4646f
Iteration: --- → 59.4 - Jan 15
Target Milestone: --- → Firefox 59
I have verified that the issue is no longer reproducible on the latest Nightly build (Build ID 	20180121220252) using Windows 10 x64, Mac 10.12 and Ubuntu 14.04.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.