Closed Bug 1404036 Opened 2 years ago Closed 2 years ago

[10.13] Window titles not showing with non-default themes and titlebars displayed

Categories

(Core :: Widget: Cocoa, defect, P1)

57 Branch
Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- verified
firefox58 --- verified

People

(Reporter: spohl, Assigned: spohl)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. Select non-default theme, such as "Light" or "Dark".
2. Customize UI to display titlebars
3. Close and reopen Firefox

Actual:
No window titles.

Expected:
Window titles.
Blocks: 1398582
No longer blocks: 1324892
No longer depends on: 1398582, 1400517, 1401641, 1402577
Attached patch PatchSplinter Review
Assignee: nobody → spohl.mozilla.bugs
Status: NEW → ASSIGNED
Attachment #8913327 - Flags: review?(mstange)
Attachment #8913327 - Flags: review?(mstange) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e4862be7721039f6472654622e4d7c9504a58c8b
Bug 1404036: Display window titles in non-default themes when titlebars are showing on macOS. r=mstange
https://hg.mozilla.org/mozilla-central/rev/e4862be77210
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Comment on attachment 8913327 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1398582
[User impact if declined]: Window titles would not display for users with non-default themes and titlebars showing.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Isolated, well understood and tested change.
[String changes made/needed]: None
Attachment #8913327 - Flags: approval-mozilla-beta?
Comment on attachment 8913327 [details] [diff] [review]
Patch

Improve mac support, taking it.
Should be in 57b5
Attachment #8913327 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This is a user-facing bug with no automated coverage. Flagging for manual testing.
Flags: qe-verify+
QA Contact: alexandru.simonca
I have just reproduced this issue using a 2013 MacBook Pro with Firefox Beta 57.0b4 and Firefox Nightly 58.0a1 (20170927100120).
The issue is VERIFIED FIXED in Beta 57.0b5 and Nightly 58.0a1 (20171002223859).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.