Closed Bug 1404056 Opened 2 years ago Closed 2 years ago

intrinsic sizing is broken for elements that contain <img srcset>

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1149357
Tracking Status
firefox57 --- wontfix
firefox58 --- affected

People

(Reporter: dholbert, Unassigned)

Details

(Keywords: testcase, Whiteboard: [webcompat])

Attachments

(1 file)

Attached file testcase 1
STR:
 1. Load attached testcase.

EXPECTED RESULTS:
 No red should be visible.

ACTUAL RESULTS:
 Red is visible.


The teal-bordered div is supposed to shrinkwrap its contents' intrinsic width. Its only child is a blue <img> element, so all that should be visible is blue.

Chrome gives EXPECTED RESULTS. Firefox Nightly gives ACTUAL RESULTS.

The problem here is approximately:
 (1) we are making the container as wide as the underlying PNG image's *actual width* in pixels.
 (2) ...but "srcset" makes the image render at half of that native width.

This is the underlying bug that's causing this webcompat issue: https://github.com/webcompat/web-bugs/issues/10436
FWIW, I get EXPECTED RESULTS in Chrome 63 dev, Safari 10.1, and Edge 15.

So, we're the odd ones out here. (not surprising, since it seems like just a bug rather than a difference of opinion).
Priority: -- → P3
Duplicate of this bug: 1409271
Looks like it, yeah - thanks!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149357
Product: Core → Core Graveyard
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.