Text e-mail displayed as attachment when inline message/rfc822 mime part has empty Content-Type

RESOLVED DUPLICATE of bug 155537

Status

RESOLVED DUPLICATE of bug 155537
17 years ago
5 years ago

People

(Reporter: tim, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
I've received a couple of e-mails today that display as if they had an
attachment, but they are just plain text e-mails, AFAICT.
(Reporter)

Comment 1

17 years ago
Created attachment 81204 [details]
Complete message text as file attachment
(Reporter)

Comment 2

17 years ago
Created attachment 81206 [details]
Second message exhibiting same behavior
Reporter: Does this problem still occour with a newer build?
(Reporter)

Comment 4

16 years ago
Yes, just tried it with build 2002133110, Win2K
(Reporter)

Comment 5

16 years ago
er, that's build 2002103110

Updated

16 years ago
QA Contact: trix → yulian
QA Contact: yulian → stephend
Confirming with build 2002-12-13-08, Windows 2000.

I'll attach a screenshot.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

15 years ago
I expect the problem is because of this header:
  Content-Type:

Mozilla kinda likes to know exactly what it's dealing with before displaying 
anything.  Null content-type  =>  do not display.
*** Bug 159148 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Updated

11 years ago
Assignee: mscott → nobody
QA Contact: stephend → attachments
(Assignee)

Updated

11 years ago
Product: Core → MailNews Core
(In reply to Mike Cowperthwaite from comment #9)
> See bug 155537.

All three testcases of this bug have empty content-type for the attached inline mime part containing the other message, so these look like duplicates of bug 155537. Problem of empty content-type was fixed in bug 155537.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Summary: Text e-mail displayed as attachment → Text e-mail displayed as attachment when inline message/rfc822 mime part has empty Content-Type
Duplicate of bug: 155537
You need to log in before you can comment on or make changes to this bug.