Closed Bug 1404166 Opened 5 years ago Closed 5 years ago

Print preview/output and History dates have incorrect month and day (swapped)

Categories

(Core :: Internationalization, defect, P3)

54 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- wontfix
firefox56 --- wontfix
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: karlt, Assigned: zbraniecki)

References

Details

(Keywords: regression, Whiteboard: [fixed with bug 1409158])

1. Start Firefox with non-US system locale.
   e.g. LC_ALL=en_AU.UTF-8 firefox, if en_AU.UTF-8 is installed.
2. Hamburger -> Print
3. View date in corner of page.

Expected:
Correct date.

Actual:
Month and day are swapped, giving incorrect date.

Regression range:
https://hg.mozilla.org/mozilla-central/log?rev=ancestors(966464a68a2cb3ca1125808e34abb5c1d34e3797)-ancestors(eb23648534779c110f3a1f2baae1849ae4a9c570)&revcount=600
Suspect https://hg.mozilla.org/mozilla-central/rev/439f5e4ed073 for bug 1342753.

I suspect this is also the cause of incorrect dates in "Show All History"'s
"Most recent visit" column.

This likely has the same root cause as bug 1391411, but that just blocks a new
unshipped feature.  It may also be resolved through fixing bug 1337069, but
that is not tracking a regression.

I haven't been able to find an open bug tracking the regression reported here. 
There are no other bugs blocking bug 1342753.
Version: Trunk → 54 Branch
Priority: -- → P3
NI Gandalf for awareness. Maybe there is a quick fix?
Flags: needinfo?(gandalf)
Yep, the analysis is correct. We need to improve our Unix OSPreferences game (bug 1337069) to pick up `LC_ALL=en_AU`, recognize it's the same language as Firefox's en-US (but different region) and use en-AU for Intl.

I hope to get to bug 1337069 in 58.

Let's keep this bug open.
Flags: needinfo?(gandalf)
Hi Karl,

We now do a bit better job at recognizing en-AU vs en-US Firefox. Can you please check if this is fixed on the latest Nightly?

Thank you!
Flags: needinfo?(karlt)
Both print preview and history dates are now correct.  Thank you!
Assignee: nobody → gandalf
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(karlt)
Resolution: --- → FIXED
Whiteboard: [fixed with bug 1409158]
No longer blocks: 1391411
You need to log in before you can comment on or make changes to this bug.