Closed Bug 1404253 Opened 2 years ago Closed 2 years ago

Intermittent A promise chain failed to handle a rejection: Win error 2 during operation move on file bookmarks-2017-09-28.jsonlz4 (The system cannot find the file specified.

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 60
Tracking Status
firefox59 --- fixed
firefox60 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: standard8)

References

Details

(Keywords: intermittent-failure, Whiteboard: [fxsearch][stockwell fixed:other])

Attachments

(1 file)

Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=133913340&repo=autoland

https://queue.taskcluster.net/v1/task/bJFGoks2T-eSg9YZACUmgw/runs/0/artifacts/public/logs/live_backing.log

20:57:50     INFO -  337 INFO Displayed status: 101
20:57:50     INFO -  338 INFO Displayed code: 101
20:57:50     INFO -  339 INFO Tooltip status: 101 Switching Protocols
20:57:50     INFO -  340 INFO TEST-PASS | devtools/client/netmonitor/test/browser_net_filter-02.js | The displayed status is correct. -
20:57:50     INFO -  341 INFO TEST-PASS | devtools/client/netmonitor/test/browser_net_filter-02.js | The displayed status code is correct. -
20:57:50     INFO -  342 INFO TEST-PASS | devtools/client/netmonitor/test/browser_net_filter-02.js | The tooltip status is correct. -
20:57:50     INFO -  343 INFO TEST-PASS | devtools/client/netmonitor/test/browser_net_filter-02.js | Item should have 'even' class. -
20:57:50     INFO -  344 INFO TEST-PASS | devtools/client/netmonitor/test/browser_net_filter-02.js | Item shouldn't have 'odd' class. -
20:57:50     INFO -  345 INFO Destroying the specified network monitor.
20:57:50     INFO -  346 INFO Removing tab.
20:57:50     INFO -  347 INFO Waiting for event: 'TabClose' on [object XULElement].
20:57:50     INFO -  348 INFO Got event: 'TabClose' on [object XULElement].
20:57:50     INFO -  349 INFO Tab removed and finished closing
20:57:50     INFO -  Buffered messages finished
20:57:50    ERROR -  350 INFO TEST-UNEXPECTED-FAIL | devtools/client/netmonitor/test/browser_net_filter-02.js | A promise chain failed to handle a rejection: Win error 2 during operation move on file C:\Users\GenericWorker\AppData\Local\Temp\tmpoayezb.mozrunner\bookmarkbackups\bookmarks-2017-09-28.jsonlz4 (The system cannot find the file specified.
20:57:50     INFO -  ) - stack: null
20:57:50     INFO -  Rejection date: Thu Sep 28 2017 20:57:38 GMT+0000 (Coordinated Universal Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 265
20:57:50     INFO -  Stack trace:
20:57:50     INFO -      resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:265
20:57:50     INFO -      chrome://mochikit/content/browser-test.js:Tester_execTest/<:829
20:57:50     INFO -      Tester_execTest@chrome://mochikit/content/browser-test.js:798:9
20:57:50     INFO -      Tester.prototype.nextTest</<@chrome://mochikit/content/browser-test.js:697:9
20:57:50     INFO -      SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:795:59
20:57:50     INFO -  351 INFO Leaving test bound
Hit an animation test this time: https://treeherder.mozilla.org/logviewer.html#?job_id=134295158&repo=autoland

Marco, are there any recent changes to bookmark backups?
Component: Developer Tools: Netmonitor → Bookmarks & History
Flags: needinfo?(mak77)
Summary: Intermittent devtools/client/netmonitor/test/browser_net_filter-02.js | A promise chain failed to handle a rejection: Win error 2 during operation move on file bookmarks-2017-09-28.jsonlz4 (The system cannot find the file specified. → Intermittent A promise chain failed to handle a rejection: Win error 2 during operation move on file bookmarks-2017-09-28.jsonlz4 (The system cannot find the file specified.
Interesting, it doesn't look like nsBrowserglue, as we seem to be quite a way from startup, but it could be idle kicking in.

Maybe we should set browser.bookmarks.max_backups to 0 as it is for the talos tests?
(In reply to Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) from comment #2)
> Marco, are there any recent changes to bookmark backups?

I don't know of any recent changes to backups.
Off-hand this looks like OS.File.writeAtomic failing to atomically move the file. Could be anything.

It's surely idle kicking in and the bookmarks backup code in nsBrowserGlue runs.

(In reply to Mark Banner (:standard8) from comment #3)
> Maybe we should set browser.bookmarks.max_backups to 0 as it is for the
> talos tests?

Sounds good to me, the only other alternative would be to disable idle, but the only way (currently) would be to mock the idle service.
Flags: needinfo?(mak77)
Duplicate of this bug: 1412462
Duplicate of this bug: 1417534
Duplicate of this bug: 1402651
Duplicate of this bug: 1423737
Duplicate of this bug: 1424062
Duplicate of this bug: 1424431
Duplicate of this bug: 1424558
Duplicate of this bug: 1424736
Duplicate of this bug: 1424882
Duplicate of this bug: 1425007
Duplicate of this bug: 1425162
Duplicate of this bug: 1425327
Duplicate of this bug: 1425774
Duplicate of this bug: 1425549
Duplicate of this bug: 1425753
Duplicate of this bug: 1426320
Duplicate of this bug: 1426903
Duplicate of this bug: 1428238
Duplicate of this bug: 1428789
This seems to be happening a lot and isn't associated with just one test, going to bump the priority and stick in my queue, hopefully for later this week.
Assignee: nobody → standard8
Priority: P5 → P2
Whiteboard: [fxsearch]
Duplicate of this bug: 1430343
Duplicate of this bug: 1431897
Just to clarify, we're not sure what changed to start triggering this, my best guess is that there's some async work going on and the profile is getting cleaned up/changed before it is complete & causing the errors.
Comment on attachment 8946265 [details]
Bug 1404253 - Disable places' bookmarks backups in mochitests to avoid intermittent failures.

https://reviewboard.mozilla.org/r/216222/#review222722

SGTM

::: testing/profiles/prefs_general.js:398
(Diff revision 1)
>  // int32_t) to avoid it kicking in during tests. The maintenance can take a
>  // relatively long time which may cause unnecessary intermittents and slow down
>  // tests. This, like many things, will stop working correctly in 2038.
>  user_pref("places.database.lastMaintenance", 2147483647);
> +
> +// Disable places' backups by default.

s/places'/Bookmark/
Attachment #8946265 - Flags: review?(mak77) → review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f88c5b822178
Disable places' bookmarks backups in mochitests to avoid intermittent failures. r=mak
https://hg.mozilla.org/mozilla-central/rev/f88c5b822178
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Whiteboard: [fxsearch] → [fxsearch][stockwell fixed:other]
You need to log in before you can comment on or make changes to this bug.