Build-in XML viewer broken with particular add-ons

RESOLVED DUPLICATE of bug 1401793

Status

RESOLVED DUPLICATE of bug 1401793
a year ago
7 months ago

People

(Reporter: bugzilla, Unassigned)

Tracking

57 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170925150345

Steps to reproduce:

Go to http://census.daybreakgames.com/xml/get/eq2/ or http://census.daybreakgames.com/xml/get/eq2/character/863289273747 which sends output as Content-Type: application/xml;charset=UTF-8


Actual results:

Get either blank screen, long series of numbers, or unformatted text.  Screenshot of example: https://i.imgur.com/SsAZszj.png


Expected results:

I expected what previous versions would do and display a formatted output like this image: https://i.imgur.com/rWnXNvD.png

Not sure if this change is an intentional thing or not in 57.

Comment 1

a year ago
I see the issue with https://addons.mozilla.org/firefox/addon/tampermonkey/versions/?page=1#version-4.3.5430 and later + https://greasyfork.org/scripts/10433-super-preloaderplus-one on http://www.w3school.com.cn/example/xmle/note.xml, on Fx52~58.

"Allow scripts to run at XML pages | thanks to Thom1729 for the slight lead" on Tampermonkey 4.3.5430.
Status: UNCONFIRMED → NEW
Component: Untriaged → Extension Compatibility
Ever confirmed: true
Summary: View XML Files Like Version 56 and Below → Build-in XML viewer broken
(Reporter)

Comment 2

a year ago
It started working. I then discovered that if The Hover Zoom+ extension is enabled, it causes it: https://addons.mozilla.org/en-US/firefox/addon/hover-zoom/?src=search

With Imagus enabled instead, it views the XML files normally.  https://addons.mozilla.org/en-US/firefox/addon/imagus/?src=ss

So yeah, the built-in XML viewer seems to stop working when certain extensions are installed.

Updated

a year ago
Component: Extension Compatibility → XML
Product: Firefox → Core
Summary: Build-in XML viewer broken → Build-in XML viewer broken with particular add-ons
Bug 1401793 looks like the same issue.

Updated

a year ago
See Also: → bug 1401793

Updated

a year ago
See Also: → bug 1404933
(In reply to MarkRH from comment #2)
> It started working. I then discovered that if The Hover Zoom+ extension is
> enabled, it causes it:
> https://addons.mozilla.org/en-US/firefox/addon/hover-zoom/?src=search
> 
> With Imagus enabled instead, it views the XML files normally. 
> https://addons.mozilla.org/en-US/firefox/addon/imagus/?src=ss
> 
> So yeah, the built-in XML viewer seems to stop working when certain
> extensions are installed.

Given the issue happened when certain extensions are installed, doesn't Tech Evangelism:Add-ons sound a better module fit for this issue?

Comment 5

a year ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #4)
> (In reply to MarkRH from comment #2)
> > It started working. I then discovered that if The Hover Zoom+ extension is
> > enabled, it causes it:
> > https://addons.mozilla.org/en-US/firefox/addon/hover-zoom/?src=search
> > 
> > With Imagus enabled instead, it views the XML files normally. 
> > https://addons.mozilla.org/en-US/firefox/addon/imagus/?src=ss
> > 
> > So yeah, the built-in XML viewer seems to stop working when certain
> > extensions are installed.
> 
> Given the issue happened when certain extensions are installed, doesn't Tech
> Evangelism:Add-ons sound a better module fit for this issue?

Bug 1401793 sitting there. Considering that this seems to affect multiple add-ons, should it be attributed to the WebExtensions component?
(In reply to YF (Yang) from comment #5)
> (In reply to Hsin-Yi Tsai [:hsinyi] from comment #4)
> > (In reply to MarkRH from comment #2)
> > > It started working. I then discovered that if The Hover Zoom+ extension is
> > > enabled, it causes it:
> > > https://addons.mozilla.org/en-US/firefox/addon/hover-zoom/?src=search
> > > 
> > > With Imagus enabled instead, it views the XML files normally. 
> > > https://addons.mozilla.org/en-US/firefox/addon/imagus/?src=ss
> > > 
> > > So yeah, the built-in XML viewer seems to stop working when certain
> > > extensions are installed.
> > 
> > Given the issue happened when certain extensions are installed, doesn't Tech
> > Evangelism:Add-ons sound a better module fit for this issue?
> 
> Bug 1401793 sitting there. Considering that this seems to affect multiple
> add-ons, should it be attributed to the WebExtensions component?

Your suggestion sounds even more sensible. Let's move to Webextesions component to get extension folks feedback. :)
Component: XML → WebExtensions: Untriaged
Product: Core → Toolkit
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1401793
Duplicate of this bug: 1414845
Duplicate of this bug: 1418181

Updated

7 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.