Closed Bug 1404318 Opened 3 years ago Closed 3 years ago

Colon sign is displayed in "about:preferences#privacy" page in Clear history sub-dialog

Categories

(Firefox :: Preferences, defect, P3)

57 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- wontfix
firefox58 --- verified

People

(Reporter: phorea, Assigned: rickychien)

References

(Blocks 1 open bug)

Details

(Whiteboard: [photon-preference])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1399075 +++

[Affected versions]: 
Nightly 58.0a1
Firefox 57.0 beta 4

[Affected platforms]:
Platforms: Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Open firefox.
2. Go to "about:preferences#privacy" - History sub-section
3. Check "Clear history when Nightly closes" option and then click on "Settings..." button.

[Expected result]:
All colon signs on sub-dialogs should be removed.

[Actual result]:
Colon sign is displayed in "Settings for Clearing History" sub-dialog, on "When I quit Nightly, it should automatically clear all:" sentence

[Note]:
On Cookies sub-dialog, there are colons for every cookie property (eg: "Name: abc")
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Flags: qe-verify+
Priority: -- → P1
QA Contact: hani.yacoub
Comment on attachment 8914144 [details]
Bug 1404318 - Remove redundant colon sign in preferences/sanitize.xul

https://reviewboard.mozilla.org/r/185464/#review190474
Attachment #8914144 - Flags: review?(jaws) → review+
Changing to wontfix for 57 since this touches strings and 57-Beta is string frozen.
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/98a81519d59d
Remove redundant colon sign in preferences/sanitize.xul r=jaws
https://hg.mozilla.org/mozilla-central/rev/98a81519d59d
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Verified as fixed in Nightly 58.0a1 2017-10-04 under Win 10 64-bit and Mac OS X 10.12.

Are the colons in Cookies details section [1] expected or should I file a new bug for that? Thank you!

[1] https://drive.google.com/file/d/0B7jBNZBM3mz-R0VHOVpLdG1nc3c/view?usp=sharing
Status: RESOLVED → VERIFIED
Flags: qe-verify+ → needinfo?(jaws)
Sorry, wrong flag.
Flags: needinfo?(jaws) → needinfo?(rchien)
It's by design, thanks!
Flags: needinfo?(rchien)
Priority: P1 → P3
You need to log in before you can comment on or make changes to this bug.