Closed Bug 1404337 Opened 2 years ago Closed 2 years ago

titlebar-placeholders appear in maximized Windows windows

Categories

(Firefox :: Theme, defect, P1)

57 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: johannh, Assigned: johannh)

References

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(1 file)

This was a small oversight from bug 1397265.
Duplicate of this bug: 1404417
Comment on attachment 8913790 [details]
Bug 1404337 - Fix titlebar-placeholders showing in maximized windows on Windows.

https://reviewboard.mozilla.org/r/185162/#review190198
Attachment #8913790 - Flags: review?(dao+bmo) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2230263c5daa
Fix titlebar-placeholders showing in maximized windows on Windows. r=dao
Hmm, looking at the build with this patch and it doesn't look good IMO, since this patch removed the space on both sides of the tab bar in maximized mode... 
See https://s26.postimg.org/gfesvhp6x/no_space.png
As per https://bugzilla.mozilla.org/show_bug.cgi?id=1397265#c3 I believe the initial intention was "only" to increase the space next to the windows control buttons, or I'm missing something.
Flags: needinfo?(jhofmann)
https://hg.mozilla.org/mozilla-central/rev/2230263c5daa
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
(In reply to Eddward from comment #5)
> Hmm, looking at the build with this patch and it doesn't look good IMO,
> since this patch removed the space on both sides of the tab bar in maximized
> mode... 
> See https://s26.postimg.org/gfesvhp6x/no_space.png
> As per https://bugzilla.mozilla.org/show_bug.cgi?id=1397265#c3 I believe the
> initial intention was "only" to increase the space next to the windows
> control buttons, or I'm missing something.

Ugghh, right, we're keeping the right hand side drag space around. Sorry. I'll follow-up in bug 1404497.
Flags: needinfo?(jhofmann)
Flags: qe-verify?
This only happened in a short interval on Nightly, I don't think it needs testing.
Flags: qe-verify? → qe-verify-
Comment on attachment 8913790 [details]
Bug 1404337 - Fix titlebar-placeholders showing in maximized windows on Windows.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1397265
[User impact if declined]: Inconsistent window drag space
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Not really. 
[List of other uplifts needed for the feature/fix]: Bug 1397265 and bug 1404497.
[Is the change risky?]: No
[Why is the change risky/not risky?]: The change is quite simple and people were extensively testing this on Nightly already. It's unlikely that we find additional problems.
[String changes made/needed]: None
Attachment #8913790 - Flags: approval-mozilla-beta?
Comment on attachment 8913790 [details]
Bug 1404337 - Fix titlebar-placeholders showing in maximized windows on Windows.

Recent regression, Beta57+
Attachment #8913790 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1404497
You need to log in before you can comment on or make changes to this bug.