Closed Bug 1404384 Opened 2 years ago Closed 2 years ago

Migrate browser_webconsole_bug_595934_message_categories.js to the new frontend

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 59

People

(Reporter: nchevobbe, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(1 file)

No description provided.
Priority: -- → P3
Priority: P3 → P2
Whiteboard: [newconsole-mvp]
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
See Also: → 1431731
try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=1c4dd5ca29a6118fb7ea2099fcd0d8f4dc6181e1

The migrated test looks a bit different, but this is mostly because the original test was using a complex machinery to test both observer events and logged messages in the hud, maintaining a complex state to transition from one test to another. Promises + async allow us to simplify this a lot.
Priority: P2 → P1
Comment on attachment 8943939 [details]
Bug 1404384 - enable browser_webconsole_message_categories;

https://reviewboard.mozilla.org/r/214280/#review220022

This looks a lot cleaner, thanks!
Attachment #8943939 - Flags: review?(bgrinstead) → review+
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0bef38b18726
enable browser_webconsole_message_categories;r=bgrins
https://hg.mozilla.org/mozilla-central/rev/0bef38b18726
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Product: Firefox → DevTools
Duplicate of this bug: 1243979
You need to log in before you can comment on or make changes to this bug.