Closed Bug 1404416 Opened 2 years ago Closed 2 years ago

webextension api to open devtools

Categories

(WebExtensions :: General, enhancement)

57 Branch
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1310037

People

(Reporter: mgueury, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [design-decision-needed])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053838

Steps to reproduce:

This is an enhancement request.

I am re-developping HTML Validator extension for Webextension.
The extension adds a panel in the devtools. I would like to be able to click
on an icon in the toolbar to start devtools and go to my tab.
In practice, I would like to click on the icon to see source of the page + the HTML errors.

But this is not existing in WebExtension API , nor in Chrome nor in FF. 



Actual results:

This is a ER
Duplicate of this bug: 1404412
Blocks: 1370525
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: web extension open devtools → webextension api to open devtools
Whiteboard: [design-decision-needed]
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1310037
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.