Closed Bug 1404495 Opened 2 years ago Closed 2 years ago

restore blue throbber to background tab loads

Categories

(Firefox :: Tabbed Browser, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 + verified
firefox58 --- verified

People

(Reporter: asa, Assigned: jaws)

References

Details

(Whiteboard: [reserve-photon-animation])

Attachments

(1 file)

At bug 1399111 we lost the blue state for the throbber in background tabs. This is information loss and misleads the user about the state of loading in background tabs. Gray is for the "Connecting" part of the load and blue is for the downloading/transferring part of the load. With it just staying gray all the time it looks like it's failing to connect on long-ish loads.
Blocks: 1399111
Whiteboard: [photon-animation][triage]
Seems like a UX question. :epang?
Flags: needinfo?(epang)
(In reply to Asa Dotzler [:asa] from comment #0)
> At bug 1399111 we lost the blue state for the throbber in background tabs.
> This is information loss and misleads the user about the state of loading in
> background tabs. Gray is for the "Connecting" part of the load and blue is
> for the downloading/transferring part of the load. With it just staying gray
> all the time it looks like it's failing to connect on long-ish loads.

We only prevent using the blue color if the tab was never selected during the loading sequence. Are you seeing this happen on tabs that have been selected while loading? What theme do you have applied? What OS are you seeing this on and do you have the Windows 10 "Show accent colors on Title Bars" enabled (and if so, what is your accent color)?
Flags: needinfo?(asa)
(In reply to Asa Dotzler [:asa] from comment #0)
> At bug 1399111 we lost the blue state for the throbber in background tabs.
> This is information loss and misleads the user about the state of loading in
> background tabs. Gray is for the "Connecting" part of the load and blue is
> for the downloading/transferring part of the load. With it just staying gray
> all the time it looks like it's failing to connect on long-ish loads.

The idea was to prevent using the blue for tabs that load in the background and were never selected (if you are seeing this anywhere else then it's a bug).  

For example: http://www.osaka-pref-rivercam.info/toubu/04.html reloads every minute.
For scenario's like this we want to keep the loading subtle so it doesn't distract the user from the current page they are on.

Thanks for the concern Asa!
Flags: needinfo?(epang)
Gray and blue aren't arbitrary. They mean something. Gray means "I'm trying to connect to the website but haven't yet" and blue means "I've connected and I'm downloading content".  When you merge the two for background tabs you destroy that information and I get the impression that my background tabs are failing to connect.
Flags: needinfo?(asa)
(In reply to Asa Dotzler [:asa] from comment #4)
> Gray and blue aren't arbitrary. They mean something. Gray means "I'm trying
> to connect to the website but haven't yet" and blue means "I've connected
> and I'm downloading content".  When you merge the two for background tabs
> you destroy that information and I get the impression that my background
> tabs are failing to connect.

Do you think the average user understands this concept?
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #5)
> (In reply to Asa Dotzler [:asa] from comment #4)
> > Gray and blue aren't arbitrary. They mean something. Gray means "I'm trying
> > to connect to the website but haven't yet" and blue means "I've connected
> > and I'm downloading content".  When you merge the two for background tabs
> > you destroy that information and I get the impression that my background
> > tabs are failing to connect.
> 
> Do you think the average user understands this concept?

(If they don't then why do we have two states at all?) I think people grok it somewhat whether they realize or not because all browsers for a long time have had two states and accompanying loading information in the status bar or similar. 

This is not only information lossy, it's misleading which is worse.
Edge doesn't show a difference between the two states. Chrome does. I didn't check Safari.
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #7)
> Edge doesn't show a difference between the two states. Chrome does. I didn't
> check Safari.

If we're going to drop the distinction, let's do it everywhere and not in some tabs but not others. The current state is just confusing to those who do understand the two states.
One other smaller point. This may matter more to people like me who have slow Internet connections. We pay attention to the loading indicators because we see them a lot more than people who have lightning fast connections. I wait for the loading indicator in background tabs to turn to the blue throbber before I switch to that tab. Try Firefox for a few days on a 1Mbit connection and see what it feels like to lose this information.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [photon-animation][triage] → [reserve-photon-animation]
Just talked with Jared about this.  Let's add the colour back in for background tabs but keep the burst at a lower opacity so it keeps the distraction low. Thanks!
[Tracking Requested - why for this release]: the patch that caused this was uplifted to beta57, this should follow to undo part of it.
Attachment #8915608 - Flags: review?(mconley) → review?(gijskruitbosch+bugs)
Comment on attachment 8915608 [details]
Bug 1404495 - Back out changeset 3e7cd55f6cb9 to go back to different colors for connecting and loading on unselected tabs.

https://reviewboard.mozilla.org/r/186798/#review191918

rs=me for backing this out.
Attachment #8915608 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8915608 [details]
Bug 1404495 - Back out changeset 3e7cd55f6cb9 to go back to different colors for connecting and loading on unselected tabs.

Approval Request Comment
[Feature/Bug causing the regression]: part of bug 1399111
[User impact if declined]: tabs loading in the background may appear to be in long "connecting" phase
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple backout of 1/2 of bug 1399111
[String changes made/needed]: none
Attachment #8915608 - Flags: approval-mozilla-beta?
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/917077cf4657
Back out changeset 3e7cd55f6cb9 to go back to different colors for connecting and loading on unselected tabs. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/917077cf4657
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8915608 [details]
Bug 1404495 - Back out changeset 3e7cd55f6cb9 to go back to different colors for connecting and loading on unselected tabs.

Photon related, beta57+
Attachment #8915608 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
See Also: → 1408007
Reproduced this issue on Nightly build 57.0a1 (2017-10-04) and Beta 57.0b6

Verified fixed on latest Nightly 58.0a1 (2017-10-16) and Beta 57.0b8 (20171013042429) across platforms: Windows 10 x64, Windows 7 x64, Mac OS X 10.13 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.