Closed Bug 1404638 Opened 2 years ago Closed 2 years ago

Legacy extensions are disabled in SeaMonkey 2.54

Categories

(SeaMonkey :: Build Config, defect, critical)

All
Unspecified
defect
Not set
critical

Tracking

(seamonkey2.54 fixed, seamonkey2.55 fixed)

VERIFIED FIXED
seamonkey2.55
Tracking Status
seamonkey2.54 --- fixed
seamonkey2.55 --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1402471 +++

Unfortinately the MOZ_ALLOW_LEGACY_EXTENSIONS=1 statement added in Bug 1373375 is not effective. This needs to go into all mozconfigs.
I shuffled around the signing options too because they are also needed in all builds.

Firefox uses a similiar common file (I can't find where it is included). 

Jorg let me know what you think and I will do TB configs for Bug 1402471 too.
Attachment #8913991 - Flags: review?(iann_bugzilla)
Attachment #8913991 - Flags: review?(ewong)
Attachment #8913991 - Flags: feedback?(jorgk)
Comment on attachment 8913991 [details] [diff] [review]
1404638-legacyenable.patch

Looks good to me. So the confvars.sh thing isn't enough? Can you explain.
Attachment #8913991 - Flags: feedback?(jorgk) → feedback+
> Can you explain.

Was probaly broken by bug 1363897. /mozilla//toolkit/moz.configure does not seem to care about the confvars.sh variable here.
Comment on attachment 8913991 [details] [diff] [review]
1404638-legacyenable.patch

>+++ b/suite/config/mozconfigs/linux32/nightly
>@@ -1,11 +1,12 @@
> . "$topsrcdir/build/unix/mozconfig.linux32"
>+. "$topsrcdir/build/mozconfig.stylo"
> . "$topsrcdir/suite/config/mozconfigs/mozconfig.linux.common"
>+. "$topsrcdir/suite/config/mozconfigs/common"

>+++ b/suite/config/mozconfigs/linux32/release
>@@ -1,11 +1,12 @@
> . "$topsrcdir/build/unix/mozconfig.linux32"
>+. "$topsrcdir/build/mozconfig.stylo"
>+. "$topsrcdir/suite/config/mozconfigs/common"
> . "$topsrcdir/suite/config/mozconfigs/mozconfig.linux.common"
Nit: this seems to be in a different order to the other nightly/release files.

>+++ b/suite/config/mozconfigs/linux64/nightly
>@@ -1,11 +1,12 @@
> . "$topsrcdir/build/unix/mozconfig.linux"
>+. "$topsrcdir/build/mozconfig.stylo"
> . "$topsrcdir/suite/config/mozconfigs/mozconfig.linux.common"
>+. "$topsrcdir/suite/config/mozconfigs/common"

>+++ b/suite/config/mozconfigs/linux64/release
>@@ -1,11 +1,12 @@
> . "$topsrcdir/build/unix/mozconfig.linux"
>+. "$topsrcdir/build/mozconfig.stylo"
> . "$topsrcdir/suite/config/mozconfigs/mozconfig.linux.common"
>+. "$topsrcdir/suite/config/mozconfigs/common"

>+++ b/suite/config/mozconfigs/macosx64/nightly
>@@ -1,24 +1,20 @@
> . $topsrcdir/build/macosx/mozconfig.common
> . $topsrcdir/suite/config/mozconfigs/mozconfig.macosx.common
>+. $topsrcdir/suite/config/mozconfigs/common

>+++ b/suite/config/mozconfigs/macosx64/release
>@@ -1,21 +1,17 @@
> . $topsrcdir/build/macosx/mozconfig.common
> . $topsrcdir/suite/config/mozconfigs/mozconfig.macosx.common
>+. $topsrcdir/suite/config/mozconfigs/common

>+++ b/suite/config/mozconfigs/win32/nightly
>@@ -1,27 +1,24 @@
> . "$topsrcdir/build/mozconfig.win-common"
> . "$topsrcdir/build/mozconfig.common"
>+. "$topsrcdir/build/mozconfig.stylo"
>+. $topsrcdir/build/win32/mozconfig.vs-latest"
> . "$topsrcdir/suite/config/mozconfigs/mozconfig.win.common"
>+. "$topsrcdir/suite/config/mozconfigs/common"

>+++ b/suite/config/mozconfigs/win32/release
>@@ -1,27 +1,22 @@
> . "$topsrcdir/build/mozconfig.win-common"
> . "$topsrcdir/build/mozconfig.common"
>+. "$topsrcdir/build/mozconfig.stylo"
>+. "$topsrcdir/build/win32/mozconfig.vs-latest"
> . "$topsrcdir/suite/config/mozconfigs/mozconfig.win.common"
>+. "$topsrcdir/suite/config/mozconfigs/common"

>+++ b/suite/config/mozconfigs/win64/nightly
>@@ -1,30 +1,25 @@
> . "$topsrcdir/build/mozconfig.win-common"
> . "$topsrcdir/build/mozconfig.common"
>+. "$topsrcdir/build/mozconfig.stylo"
>+. "$topsrcdir/build/win64/mozconfig.vs-latest"
> . "$topsrcdir/suite/config/mozconfigs/mozconfig.win.common"
>+. "$topsrcdir/suite/config/mozconfigs/common"

>+++ b/suite/config/mozconfigs/win64/release
>@@ -1,30 +1,25 @@
> . "$topsrcdir/build/mozconfig.win-common"
> . "$topsrcdir/build/mozconfig.common"
>+. "$topsrcdir/build/mozconfig.stylo"
>+. "$topsrcdir/build/win64/mozconfig.vs-latest"
> . "$topsrcdir/suite/config/mozconfigs/mozconfig.win.common"
>+. "$topsrcdir/suite/config/mozconfigs/common"

Is it worth sourcing $topsrcdir/suite/config/mozconfigs/common in $topsrcdir/suite/config/mozconfigs/mozconfig.linux.common, $topsrcdir/suite/config/mozconfigs/mozconfig.macosx.common and $topsrcdir/suite/config/mozconfigs/mozconfig.win.common rather than adding it to each individual nightly/release file or does that make things to convoluted?
r=me with nit fixed and point answered/addressed.
Attachment #8913991 - Flags: review?(iann_bugzilla) → review+
Thanks fixed the nit.

> Is it worth sourcing $topsrcdir/suite/config/mozconfigs/common in $topsrcdir/suite/config...

I thought about it too but common would then have ended in some configs directly and others indirectly so I put it in all of them for clarity. I think we could further streamline this e.g.
enable-application=suite needs to be in every config too. Mabe we should redo this all when we build a new infra.
Comment on attachment 8913991 [details] [diff] [review]
1404638-legacyenable.patch

ewong doesn't seem to be online today so lets just see if it sticks or needs to be backed out :)
Attachment #8913991 - Flags: review?(ewong)
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/2f034b0789b5
Enable legacy extensions in SeaMonkey configs. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.55
Comment on attachment 8913991 [details] [diff] [review]
1404638-legacyenable.patch

Lets wait a day or two and see if this builds.

[Approval Request Comment]
Regression caused by (bug #): 1363897
User impact if declined: addons do not work
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): none already broken
String changes made by this patch: --
Attachment #8913991 - Flags: approval-comm-beta?
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/c6fafa3db46a
Followup fix for incorrect double quotes. rs=bustage-fix
I just downloaded checked it with the latest comm-beta linux x64 builds and the fix is effective.

disables all extensions:
https://archive.mozilla.org/pub/seamonkey/tinderbox-builds/comm-beta-linux64/1507006875/

The additional whitelist in our prefs seems to be ineffectve. Even distributed addones are disabled without the patch.

extensions are left enabled:
https://archive.mozilla.org/pub/seamonkey/tinderbox-builds/comm-beta-linux64/1507031371/
Status: RESOLVED → VERIFIED
Comment on attachment 8913991 [details] [diff] [review]
1404638-legacyenable.patch

a=me
Attachment #8913991 - Flags: approval-comm-beta? → approval-comm-beta+
upps already pushed it before approval...
You need to log in before you can comment on or make changes to this bug.