Closed Bug 1404701 Opened 4 years ago Closed 2 years ago

Low WebGL FPS compared to Chrome in a very simple scene

Categories

(Core :: Canvas: WebGL, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1010527
Tracking Status
firefox55 --- fix-optional
firefox56 --- fix-optional
firefox57 --- fix-optional
firefox58 --- wontfix
firefox59 --- ?

People

(Reporter: vlad, Unassigned)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170901071738

Steps to reproduce:

Open https://threejs.org/examples/#webgl_camera — three.js demo with a very simple graphics

Additional details:

Performance profile: https://perfht.ml/2wrDQfh
OS: Fedora 26, Linux 4.12
glxinfo: https://paste.fedoraproject.org/paste/8jkX~TJ00IiIfwQbUTvxMg
lshw: https://paste.fedoraproject.org/paste/lqkQpYlpr9fDqHYJg5z8bg
telemetry JSON: https://paste.fedoraproject.org/paste/IsESibcLS790RbxblCzjig


Actual results:

Got about 25 FPS


Expected results:

FPS should be 60 — as it is with Chrome
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Vlad, is this something you're seeing with 55 and not earlier versions of Firefox, or a general observation?
Flags: needinfo?(vlad)
Priority: -- → P3
Whiteboard: [gfx-noted]
55 is just a browser I used to report this bug. I'm seeing the problem with 57. In 55, framerate is even lower than in 57.
Flags: needinfo?(vlad)
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: slow-linux-webgl
You need to log in before you can comment on or make changes to this bug.