Closed Bug 1404822 Opened 4 years ago Closed 2 years ago

Attachments are not forwarded when overall MIME structure is multipart/related - Make TB more tolerant to incorrect MIME structure: Attachment in multipart/related

Categories

(Thunderbird :: Message Compose Window, defect)

52 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 408114

People

(Reporter: kpdozer, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36

Steps to reproduce:

I receive a regular mailing. I click on the Forward button


Actual results:

The attachment disappears from the message.


Expected results:

The letter should completely correspond to the original, including attachments.
Attachment #8914236 - Attachment mime type: message/rfc822 → text/plain
The message has an invalid MIME structure. Overall structure multipart/related. It should be multipart/mixed.
Severity: normal → enhancement
Summary: not forward attachments → Attachments are not forwarded when overall MIME structure is multipart/related - Make TB more tolerant to incorrect MIME structure: Attachment in multipart/related
Can I bypass this situation at this time?
No you can't. You'd need to save all attachments and then attach them to the forwarded message.

I find it quite irritating that this message which appears to have originated from an automated system is invalid. Maybe talk to the sender so that they can rectify their system to comply with international standards.
I'm as annoyed as you, because I understand what you're talking about.
It's absurd, but for forwarding to another box I had to connect 2 mailboxes in TB by imap and make a copy of the letter from one mailbox to another.

Unfortunately, it is not possible to influence the sender. In addition, the user does not understand anything in the standards, but he can compare the work of TB with other email clients.

My suggestion is that in case of sending a "bad" letter TB would give a warning about it and give a choice to fix it, or send it in its original form.
Thanks.
Please understand that we don't have many resources for things like this. Other members of the team would have closed the bug as INVALID (as the data is invalid) quoting international standards.

The MIME component in TB is absolutely high risk, so we will not consider this enhancement ever. That said, I have a few bugs with title "Make TB more tolerant to ..." and if we ever re-implement MIME, we will consider making it more robust.

Let me file a meta bug for this.
I understand, thanks for your understanding and your work.
(In reply to kpdozer from comment #2)
> Can I bypass this situation at this time?

I see two workarounds:

A) Do use: Message -> Forward As -> Attachment

B) There is a special view to display faulty messages. When forwarding from this view, the attachments are contained in a forwarded message.

To enable this View, you must first change a preference:

Menu: Tools -> Options -> //Advanced\\ -> /General\ -> [Config Editor]

Search for 'mailnews.display.show_all_body_parts_menu' and set it to TRUE

Now you can enable:

Menu: View -> Message Body As -> All Body Parts

Now really every part gets attached. You may delete unwanted parts before sending.
Duplicate of this bug: 571669
Duplicate of this bug: 1584383
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408114
You need to log in before you can comment on or make changes to this bug.