Closed Bug 1404849 Opened 2 years ago Closed 2 years ago

Migrate browser_webconsole_bug_632347_iterators_generators.js to the new frontend

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 59

People

(Reporter: nchevobbe, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(1 file)

No description provided.
Priority: -- → P3
Priority: P3 → P2
Whiteboard: [newconsole-mvp]
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
For this one, the existing test checks two things:
- that js-property-provider does not run a generator's next() method when retrieving autocomplete suggestions
- that a generator is displayed as "Generator" in the variables view

I think the first part is more suited to be tested in the dedicated xpc-shell test for js-property-provider.
For the second part we could either have a very simple test where we log a generator, expand the Object Inspector and check that the generator has a display name of "Generator" ... or we could add a new reps test dedicated to generators. Let me know what you prefer. 

try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=229f7dea0a2fc9b8ab370448e9ef86347623ee4e
This is similar to Bug 1406841, where I migrated the existing test. I was concerned that using a Sandbox might not cover all use cases compared to using a real window object.
See Also: → 1406841
I agree about creating a Reps test for the generator.
I filed an issue for this https://github.com/devtools-html/devtools-core/issues/890
Comment on attachment 8941376 [details]
Bug 1404849 - migrate mochitest for generators autocompletion to xpcshell;

https://reviewboard.mozilla.org/r/211690/#review217472

This looks good to me, thanks Julian
Attachment #8941376 - Flags: review?(nchevobbe) → review+
Priority: P2 → P1
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/48cb9676ec2c
migrate mochitest for generators autocompletion to xpcshell;r=nchevobbe
https://hg.mozilla.org/mozilla-central/rev/48cb9676ec2c
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Product: Firefox → DevTools
Duplicate of this bug: 1243985
You need to log in before you can comment on or make changes to this bug.