Closed Bug 1404914 Opened 5 years ago Closed 5 years ago

Intermittent dom/workers/test/serviceworkers/browser_multie10s_update.js | Test timed out -

Categories

(Core :: DOM: Service Workers, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1429794

People

(Reporter: intermittent-bug-filer, Assigned: baku)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell disabled])

Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=134401583&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/X6toFH6SR5esMYj99QL9AA/runs/0/artifacts/public/test_info/browser-chrome-chunked_errorsummary.log

07:05:48     INFO - TEST-START | dom/workers/test/serviceworkers/browser_multie10s_update.js
07:05:48     INFO - GECKO(1965) | 2017-10-02 07:05:48.306 plugin-container[1969:18216] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x9a57, name = 'com.apple.tsm.portname'
07:05:48     INFO - GECKO(1965) | See /usr/include/servers/bootstrap_defs.h for the error codes.
07:06:33     INFO - TEST-INFO | started process screencapture
07:06:33     INFO - TEST-INFO | screencapture: exit 0
07:06:33     INFO - Buffered messages logged at 07:05:48
07:06:33     INFO - Entering test bound test_update
07:06:33     INFO - Setting the prefs to having multi-e10s enabled
07:06:33     INFO - Creating the first tab...
07:06:33     INFO - Console message: [JavaScript Warning: "Use of nsIFile in content process is deprecated." {file: "resource://gre/modules/FileUtils.jsm" line: 174}]
07:06:33     INFO - Creating the second tab...
07:06:33     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://mochi.test:8888/browser/dom/workers/test/serviceworkers/file_multie10s_update.html" line: 0}]
07:06:33     INFO - Console message: [JavaScript Warning: "Unknown property ‘-moz-window-opacity’.  Declaration dropped." {file: "chrome://global/content/xul.css" line: 438}]
07:06:33     INFO - Console message: [JavaScript Warning: "Unknown property ‘-moz-window-transform’.  Declaration dropped." {file: "chrome://global/content/xul.css" line: 439}]
07:06:33     INFO - Console message: [JavaScript Warning: "Unknown property ‘-moz-window-transform’.  Declaration dropped." {file: "chrome://global/content/xul.css" line: 447}]
07:06:33     INFO - Console message: [JavaScript Warning: "Unknown property ‘-moz-window-opacity’.  Declaration dropped." {file: "chrome://global/content/xul.css" line: 451}]
07:06:33     INFO - Console message: [JavaScript Warning: "Unknown property ‘-moz-window-transform’.  Declaration dropped." {file: "chrome://global/content/xul.css" line: 453}]
07:06:33     INFO - Console message: [JavaScript Warning: "Unknown property ‘-moz-window-transform’.  Declaration dropped." {file: "chrome://global/content/xul.css" line: 459}]
07:06:33     INFO - Console message: [JavaScript Warning: "Unknown pseudo-class or pseudo-element ‘-moz-tree-line’.  Ruleset ignored due to bad selector." {file: "chrome://global/content/xul.css" line: 658}]
07:06:33     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://mochi.test:8888/browser/dom/workers/test/serviceworkers/file_multie10s_update.html" line: 0}]
07:06:33     INFO - Let's start the test...
07:06:33     INFO - Buffered messages finished
07:06:33     INFO - TEST-UNEXPECTED-FAIL | dom/workers/test/serviceworkers/browser_multie10s_update.js | Test timed out - 
07:06:33     INFO - GECKO(1965) | MEMORY STAT | vsize 4376MB | residentFast 335MB | heapAllocated 77MB
07:06:33     INFO - TEST-OK | dom/workers/test/serviceworkers/browser_multie10s_update.js | took 45020ms
07:06:33     INFO - Not taking screenshot here: see the one that was previously logged
07:06:33     INFO - TEST-UNEXPECTED-FAIL | dom/workers/test/serviceworkers/browser_multie10s_update.js | Found a tab after previous test timed out: http://mochi.test:8888/browser/dom/workers/test/serviceworkers/file_multie10s_update.html -
:overholt I noticed that this is failing quite frequently. Could you find anyone who can look through this failure?
Thank you.
Flags: needinfo?(overholt)
Given the pending e10s-multi rearchitecting you're working on, do you think it's worth doing anything to bandaid this patch for now, Ben?
Flags: needinfo?(overholt) → needinfo?(bkelly)
Andrea, can you investigate why this suddenly became more frequent?  If this is breaking in the wild for people it could cause profile corruption for sites.
Flags: needinfo?(bkelly) → needinfo?(amarchesini)
Assignee: nobody → amarchesini
Priority: -- → P2
our current linux64 browser-chrome tests run on really slow single core VM instances- this takes a lot of time up in getting results and is not very realistic- I can reproduce this failure at a higher rate when running on multi-core machines:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7bc76d4a5cbd30c7cff11b329cb1ff4e00e8c5df

I have 4 instances of this (basically 10%) on all flavors of linux 64 (opt/debug/stylo-disabled).  I see :baku working on this and will assume this is the same failure we are seeing on single-core machines :)

for reference here is a log file:
https://public-artifacts.taskcluster.net/dhVjh4SwQyyiDL1W7bxW4A/0/public/logs/live_backing.log

and data from the log:
[task 2017-10-14T10:46:06.041Z] 10:46:06     INFO - TEST-START | dom/workers/test/serviceworkers/browser_multie10s_update.js
[task 2017-10-14T10:46:51.054Z] 10:46:51     INFO - TEST-INFO | started process screentopng
[task 2017-10-14T10:46:51.659Z] 10:46:51     INFO - TEST-INFO | screentopng: exit 0
[task 2017-10-14T10:46:51.661Z] 10:46:51     INFO - Buffered messages logged at 10:46:06
[task 2017-10-14T10:46:51.661Z] 10:46:51     INFO - Entering test bound test_update
[task 2017-10-14T10:46:51.662Z] 10:46:51     INFO - Setting the prefs to having multi-e10s enabled
[task 2017-10-14T10:46:51.663Z] 10:46:51     INFO - Creating the first tab...
[task 2017-10-14T10:46:51.664Z] 10:46:51     INFO - Creating the second tab...
[task 2017-10-14T10:46:51.665Z] 10:46:51     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://mochi.test:8888/browser/dom/workers/test/serviceworkers/file_multie10s_update.html" line: 0}]
[task 2017-10-14T10:46:51.666Z] 10:46:51     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://mochi.test:8888/browser/dom/workers/test/serviceworkers/file_multie10s_update.html" line: 0}]
[task 2017-10-14T10:46:51.666Z] 10:46:51     INFO - Let's start the test...
[task 2017-10-14T10:46:51.667Z] 10:46:51     INFO - Buffered messages finished
[task 2017-10-14T10:46:51.667Z] 10:46:51     INFO - TEST-UNEXPECTED-FAIL | dom/workers/test/serviceworkers/browser_multie10s_update.js | Test timed out - 
[task 2017-10-14T10:46:51.669Z] 10:46:51     INFO - GECKO(5295) | MEMORY STAT | vsize 2215MB | residentFast 236MB | heapAllocated 88MB
[task 2017-10-14T10:46:51.670Z] 10:46:51     INFO - TEST-OK | dom/workers/test/serviceworkers/browser_multie10s_update.js | took 45020ms
baku told me he speculates it's probably not indicative of a real world problem and is likely a timing issue in the test.
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2dc17f71814b
Disable dom/workers/test/serviceworkers/browser_multie10s_update.js on linux and osx for frequent failures. r=me, a=testonly
please remember to re-enable this test before working on it.
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
I've done some cleanup on this test on bug 1416879, but I've also moved it to a sub-dir and am disabling.  Re-enabling is tracked on bug 1429794.  Duping over to that bug in the interest of simplified tracking.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
Flags: needinfo?(amarchesini)
You need to log in before you can comment on or make changes to this bug.