Closed Bug 1404925 Opened 2 years ago Closed 2 years ago

Add tc/bb configs for new talos speedometer test job

Categories

(Testing :: Talos, enhancement)

Version 3
enhancement
Not set

Tracking

(firefox58 fixed)

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: rwood, Assigned: rwood)

References

Details

(Whiteboard: [PI:October])

Attachments

(3 files, 1 obsolete file)

Create configs for new talos speedometer test which will be landing in Bug 1395247.
Attached patch bug1404925-buildbot.patch (obsolete) — Splinter Review
Attachment #8914442 - Flags: review?(jmaher)
Attachment #8914504 - Flags: review?(emorley)
Comment on attachment 8914504 [details] [review]
[treeherder] rwood-moz:speedometer > mozilla:master

Many thanks!
Attachment #8914504 - Flags: review?(emorley) → review+
Comment on attachment 8914442 [details] [diff] [review]
bug1404925-buildbot.patch

Review of attachment 8914442 [details] [diff] [review]:
-----------------------------------------------------------------

one change.

::: mozilla-tests/config.py
@@ +511,5 @@
>          'suites': GRAPH_CONFIG + ['--activeTests', 'bloom_basic_singleton', '--filter', 'ignore_first:5', '--filter', 'median'],
>          'options': ({}, ALL_TALOS_PLATFORMS),
>      },
> +    'speedometer-e10s': {
> +        'enable_by_default': True,

set this to false
Attachment #8914442 - Flags: review?(jmaher) → review+
Comment on attachment 8914343 [details]
Bug 1404925 - Add tc configs for new talos speedometer test job;

https://reviewboard.mozilla.org/r/185614/#review190780

this is great, but we cannot land this until we have the corresponding talos code :) - do get the buildbot changes landed though.
Attachment #8914343 - Flags: review?(jmaher) → review+
Thanks for the review, updated the buildbot patch accordingly and carrying over the r+
Attachment #8914442 - Attachment is obsolete: true
Attachment #8914743 - Flags: review+
Landed the buildbot configs:

https://hg.mozilla.org/build/buildbot-configs/rev/aa469888ed3b04084ba4d8ddda0a369573394df6

Will land the tc configs only after Bug 1395247 has landed.
Whiteboard: [PI:October]
a note, the tc configs will fail due to speedometer being out of alphanumeric order in the test list.
(In reply to Joel Maher ( :jmaher) (UTC-5) from comment #10)
> a note, the tc configs will fail due to speedometer being out of
> alphanumeric order in the test list.

Thanks! I updated the patch accordingly and pushed to mozreview, just carried fw the existing r+
Pulled in latest and fixed rebase conflict, updated try run:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=3b9456e538464ebdd9d01a0b56da753156d4bb1f
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/888796477f55
Add tc configs for new talos speedometer test job; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/888796477f55
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.