Page that starts with <! doctype shows source, not page

RESOLVED DUPLICATE of bug 133653

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 133653
16 years ago
13 years ago

People

(Reporter: Jerry, Assigned: Matti)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

http://www.christianword.org/discipleship.shtml
!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN"
at the above site the first line in the web page is a tag
with an "!" in the first char followed by doctype ----
this causes the browser to display the source code and
ie it never sees the html tag.

Reproducible: Always
Steps to Reproduce:
1.go to the above url
2.boom!
3.

Expected Results:  should have found the html tag and displayed the web page,
not the source
Actually, the "<!DOCTYPE" part is absolutely _required_ to be a valid HTML document.

The way that this whole thing works in every browser except IE is that the
server tells the browser what type of data it's sending and the browser acts
accordingly.  This server is telling us that it's sending text/plain data (HTML
is text/html).
IE shows the page because it violates the quite clear rule that the server
determines the data type -- IE ignores the server type and scans the file trying
to decide the type on its own... Quite often this leads to serious problems, as
it happens.


*** This bug has been marked as a duplicate of 133653 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.