Closed Bug 1405352 Opened 2 years ago Closed 2 years ago

Migrate browser_webconsole_jsterm.js to the new frontend

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(firefox60 fixed)

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Blocks 1 open bug)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(1 file)

No description provided.
Priority: -- → P3
Priority: P3 → P2
Whiteboard: [newconsole-mvp]
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment on attachment 8948982 [details]
Bug 1405352 - Split browser_webconsole_jsterm.js in multiple tests; .

https://reviewboard.mozilla.org/r/216862/#review226476

Very nice clean up!
Just couple of notes.

R+ assuming try is green
Honza

::: devtools/client/webconsole/new-console-output/test/mochitest/browser_jsterm_error_docs.js:12
(Diff revision 1)
>  
> -var jsterm;
> +add_task(async function () {
> +  const hud = await openNewTabAndConsole(TEST_URI);
> +  const {jsterm} = hud;
>  
> -add_task(function* () {
> +  // Check that errors with entires in errordocs.js display links next to their messages.

typo: entires -> entries

::: devtools/client/webconsole/new-console-output/test/mochitest/browser_jsterm_error_docs.js
(Diff revision 1)
> -    }, `error links to ${title}`);
> -  }
> -
> +    const learnMoreLink = node.querySelector(".learn-more-link");
> +    ok(learnMoreLink, `There is a [Learn More] link for "${errorMessageName}" error`);
> +    is(learnMoreLink.title, title, `The link has the expected "${title}" title`);
> -  // Ensure that dom errors, with error numbers outside of the range
> -  // of valid js.msg errors, don't cause crashes (bug 1270721).
> -  yield jsterm.execute("new Request('',{redirect:'foo'})");

What was this for? Not necessary anymore?
Attachment #8948982 - Flags: review?(odvarko) → review+
Comment on attachment 8948982 [details]
Bug 1405352 - Split browser_webconsole_jsterm.js in multiple tests; .

https://reviewboard.mozilla.org/r/216862/#review226476

> What was this for? Not necessary anymore?

oops, I think I missed this one
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9b0cf7518d66
Split browser_webconsole_jsterm.js in multiple tests; r=Honza.
https://hg.mozilla.org/mozilla-central/rev/9b0cf7518d66
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Product: Firefox → DevTools
Duplicate of this bug: 1243957
You need to log in before you can comment on or make changes to this bug.