Closed Bug 1405398 Opened 3 years ago Closed 5 months ago

Add `SSL` to MDN Glossary

Categories

(Developer Documentation Graveyard :: General, enhancement, P5)

All
Other
enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: russnicoletti, Unassigned)

References

()

Details

:: Developer Documentation Request

      Request Type: New Documentation
     Gecko Version: unspecified
 Technical Contact: eshepherd@mozilla.com

:: Details

I would like to add `SSL` to the MDN Glossary because it is the foundation protocol/technology for TLS; I believe the TLS entry should reference the SSL entry.
This is a good idea. If you'd like to add this glossary entry yourself, please could you email mdn-admins@mozilla.org, letting us know your MDN username? Then we can grant you the "page creation" permission.

Thanks!
Yes, I'd like to add the glossary entry myself. I've sent email to mdn-admins@mozilla.org with my MDN username.
MDN already had an SSL entry in the glossary. It simply redirected to TLS and referred to the fact that it was the successor to SSL. You can see that by going here:

https://developer.mozilla.org/en-US/docs/Glossary/SSL

We probably shouldn't have this:
https://developer.mozilla.org/en-US/docs/Glossary/SSL_Glossary

Since that's kind of a weird document URL.  :)

As for TLS, I'm going to mostly revert this change:
https://developer.mozilla.org/en-US/docs/Glossary/TLS

This is because we try to only refer to TLS inside MDN (to prevent confusion), and a glossary entry should say what something is in the hover tooltips, not say that it was the successor to something else that has been deprecated for 20 years.
I see your point and agree this should be removed:
https://developer.mozilla.org/en-US/docs/Glossary/SSL_Glossary

Will you remove it?

I don't recall seeing an SSL entry on the glossary page before. Did I miss it or does it not appear because it is a redirect?
Flags: needinfo?(april)
IIRC it's a technical limitation of MDN to not be able to have multiple glossary entries (on the glossary page) that link to the same place. :sheppy, do you know of any way to do this?
Flags: needinfo?(april)
If SSL_Glossary is removed, there doesn't need to be two entries on the glossary page that link to the same place, correct?
It would be nice if both SSL and TLS were on that page and they both went to the TLS page.  (imo)
MDN Web Docs' bug reporting has now moved to GitHub. From now on, please file content bugs at https://github.com/mdn/sprints/issues/ and platform bugs at https://github.com/mdn/kuma/issues/.
Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.