Closed Bug 1405627 Opened 4 years ago Closed 4 years ago

WebExtensions addons doesn't work if javascript is disabled

Categories

(WebExtensions :: Untriaged, defect)

52 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1329731

People

(Reporter: sadiq, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170928210252

Steps to reproduce:

Firefox version: 52.4.0 (64-bit), Debian GNU/Linux (the default packaged version)

0. Installed uBlock origin addon[0]
1. Disabled javascript
    in about:config (set javascript.enabled to false)
2. Restarted Firefox and visited some website.

[0] https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/


Actual results:

uBlock origin wasn't working, no ads where blocked, neither my personal per element blocks.

The settings page of the addon isn't working either.


Expected results:

Disabling javascript shouldn't have any effect on installed addons.

This was reported upstream at https://github.com/gorhill/uBlock/issues/3083

Thanks
Has STR: --- → yes
Component: Untriaged → WebExtensions: Untriaged
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329731
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.