Closed Bug 1405628 Opened 3 years ago Closed 3 years ago

0.99 - 2.13% sessionrestore_many_windows (windows10-64, windows7-32) regression on push a75e0386aad86b8f9c763fdde8c1c046841b3b31 (Tue Oct 3 2017)

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox58 --- affected

People

(Reporter: igoldan, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=a75e0386aad86b8f9c763fdde8c1c046841b3b31

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  2%  sessionrestore_many_windows windows7-32 opt e10s     2,980.62 -> 3,044.17
  2%  sessionrestore_many_windows windows10-64 opt e10s    2,862.33 -> 2,905.25
  1%  sessionrestore_many_windows windows10-64 pgo e10s    3,501.75 -> 3,536.33


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=9809

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Component: Untriaged → Tabbed Browser
Mike, is there something we can do to fix these small regressions or should we accept them?
Flags: needinfo?(mconley)
We're going to be painting more text and (potentially) favicons because we're cramming more tabs into the tab strip. I think we'll have to accept these.
Flags: needinfo?(mconley)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.