Forget panelview has no bottom space

VERIFIED FIXED in Firefox 57

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
Last year

People

(Reporter: magicp.jp, Assigned: mikedeboer)

Tracking

({regression})

Trunk
Firefox 58
Points:
---
Dependency tree / graph
Bug Flags:
in-qa-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox56 unaffected, firefox57 verified, firefox58 verified)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(2 attachments)

Posted image forget-panelview.png
Steps to Reproduce:
1. Start latest Nightly.
2. Add Forget button in nav-bar.
3. Open Forget panelview.

Actual Results:
Forget panelview has no bottom space.

Expected Results:
Same with 57b

Regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=8d3e8b57fb0fbfa23f03938b65605c77dec6d96a&tochange=d4cae180f29cf400a2a125fc96cd7095cd44c3d9
Blocks: 1401991
Keywords: regression
Whiteboard: [photon-structure][triage]
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
Comment on attachment 8916927 [details]
Bug 1405942 - Make sure to always apply the descriptionHeightWorkaround in Photon panels on popupshown, because it might've missed elements that were hidden.

https://reviewboard.mozilla.org/r/187968/#review193500

Sounds good, thanks, assuming this doesn't cause additional synchronous reflows in common cases.

It looks like the assumption that Photon panel main views don't need the workaround doesn't really hold :-)
Attachment #8916927 - Flags: review?(paolo.mozmail) → review+
(In reply to :Paolo Amadini from comment #2)
> It looks like the assumption that Photon panel main views don't need the
> workaround doesn't really hold :-)

I wept, rivers :'(

;-P
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0b6c7d6bf173
Make sure to always apply the descriptionHeightWorkaround in Photon panels on popupshown, because it might've missed elements that were hidden. r=Paolo
https://hg.mozilla.org/mozilla-central/rev/0b6c7d6bf173
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8916927 [details]
Bug 1405942 - Make sure to always apply the descriptionHeightWorkaround in Photon panels on popupshown, because it might've missed elements that were hidden.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1401991
[User impact if declined]: It'll show a cut off footer of the 'Forget' widgets' panel when it's placed in the navbar.
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: No.
[Needs manual test from QE? If yes, steps to reproduce]: STR can be found in comment 0.
[List of other uplifts needed for the feature/fix]: n/a.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: Because it basically re-enables what the code did before bug 1401991; I mistakenly disabled it.
[String changes made/needed]: n/a.
Attachment #8916927 - Flags: approval-mozilla-beta?
Comment on attachment 8916927 [details]
Bug 1405942 - Make sure to always apply the descriptionHeightWorkaround in Photon panels on popupshown, because it might've missed elements that were hidden.

Photon polish, Beta57+
Attachment #8916927 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I have reproduced the issue mentioned in comment 0 using an affected Firefox 58.0a1 build (BuildId:20171004220309).

I have verified that the issue is not reproducible using Firefox 57.0b8 (Build Id:20171013042429) and Firefox 58.0a1 (BuildId:20171012220111) on Windows 10 64bit, macOS 10.11.6 and Ubuntu 16.04 64bit.
Status: RESOLVED → VERIFIED
Flags: in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.